CVE-2026-21896 Kirby is missing permission checks in the content changes API
Attackers can modify site content despite disabled update permissions in Kirby CMS when custom user roles are configured.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-21896?
CVE-2026-21896 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 8 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Kirby is an open-source content management system. From versions 5.0.0 to 5.2.1, Kirby is missing permission checks in the content changes API. This vulnerability affects all Kirby sites where user permissions are configured to prevent specific role(s) from performing write actions, specifically by disabling the update permission with the intent to prevent modifications to site content. This vulnerability does not affect those who have not altered the deviated from default user permissions. This issue has been patched in version 5.2.2.
Weakness: CWE-863
Which versions are affected by CVE-2026-21896?
2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | From 5.0.0 | 5.2.2 |
getkirby/cms Packagist | From 5.0.0 | 5.2.2 |
Products include Getkirby Kirby.
How do I fix CVE-2026-21896?
Upgrade getkirby/cms to 5.2.2 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-21896 being exploited?
There is no known exploitation of CVE-2026-21896 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-4j78-4xrm-cr2f.