# CVE-2026-21896: Kirby is missing permission checks in the content changes API

> Attackers can modify site content despite disabled update permissions in Kirby CMS when custom user roles are configured.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** GHSA-4j78-4xrm-cr2f

## What is CVE-2026-21896?

CVE-2026-21896 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 8 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kirby is an open-source content management system. From versions 5.0.0 to 5.2.1, Kirby is missing permission checks in the content changes API. This vulnerability affects all Kirby sites where user permissions are configured to prevent specific role(s) from performing write actions, specifically by disabling the update permission with the intent to prevent modifications to site content. This vulnerability does not affect those who have not altered the deviated from default user permissions. This issue has been patched in version 5.2.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-21896?

2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.2.2 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.2.2 |

Products: Getkirby Kirby.

## How do I fix CVE-2026-21896?

Upgrade getkirby/cms to 5.2.2 or later.

## Is CVE-2026-21896 being exploited?

There is no known exploitation of CVE-2026-21896 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21896 and fix it if it is affected.

What it is: CVE-2026-21896 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 8 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-21896 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.2.2
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21896/ (Markdown: https://insights.sbomify.com/CVE-2026-21896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21896
- OSV: https://osv.dev/vulnerability/CVE-2026-21896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21896/
Summaries are generated and may contain mistakes; the official description above is the record.
