{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22022 in the wild and no public exploit code.","fix":"Upgrade org.apache.solr:solr-core to 9.10.1 or later.","what":"CVE-2026-22022 is a high-severity missing authorization vulnerability in Apache Solr, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22022 and fix it if it is affected.\n\nWhat it is: CVE-2026-22022 is a high-severity missing authorization vulnerability in Apache Solr, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-22022 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.solr:solr-core (Maven): affected from 5.3.0; fixed in 9.10.1\n- org.apache.solr:solr-core (Maven): affected from 5.3.0; fixed in 9.10.1\n- solr (Bitnami): affected from 5.3.0; fixed in 9.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22022/ (Markdown: https://insights.sbomify.com/CVE-2026-22022/index.md)","id":"CVE-2026-22022","markdown":"https://insights.sbomify.com/CVE-2026-22022/index.md","name":"CVE-2026-22022","record":{"aliases":["BIT-solr-2026-22022","CLSA-2026-1792746136","GHSA-qr3p-2xj2-q7hq","MINI-p9wv-gmfx-ccg7","UBUNTU-CVE-2026-22022"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Solr search engine","requires_auth":"none","summary":"Attackers can bypass authorization rules to access restricted Solr APIs if specific permission configurations are used without the 'all' rule.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"solr","vendor":"apache"}],"cvss":{"score":8.2,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Deployments of Apache Solr 5.3.0 through 9.10.0 that rely on Solr's \"Rule Based Authorization Plugin\" are vulnerable to allowing unauthorized access to certain Solr APIs, due to insufficiently strict input validation in those components.  Only deployments that meet all of the following criteria are impacted by this vulnerability:\n\n  *  Use of Solr's \"RuleBasedAuthorizationPlugin\"\n  *  A RuleBasedAuthorizationPlugin config (see security.json) that specifies multiple \"roles\"\n  *  A RuleBasedAuthorizationPlugin permission list (see security.json) that uses one or more of the following pre-defined permission rules: \"config-read\", \"config-edit\", \"schema-read\", \"metrics-read\", or \"security-read\".\n  *  A RuleBasedAuthorizationPlugin permission list that doesn't define the \"all\" pre-defined permission\n  *  A networking setup that allows clients to make unfiltered network requests to Solr. (i.e. user-submitted HTTP/HTTPS requests reach Solr as-is, unmodified or restricted by any intervening proxy or gateway)\n\nUsers can mitigate this vulnerability by ensuring that their RuleBasedAuthorizationPlugin configuration specifies the \"all\" pre-defined permission and associates the permission with an \"admin\" or other privileged role.  Users can also upgrade to a Solr version outside of the impacted range, such as the recently released Solr 9.10.1.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Solr: Unauthorized bypass of certain \"predefined permission\" rules in the RuleBasedAuthorizationPlugin","id":"CVE-2026-22022","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"CryptoLib Has Out-of-Bounds Read in KMC AEAD Encrypt Metadata Parsing via Flawed strtok Pattern","id":"CVE-2026-22023"},"packages":[{"ecosystem":"Bitnami","fixed":["9.10.1"],"introduced":["5.3.0"],"last_affected":[],"package":"solr","purl":"pkg:bitnami/solr","source":"BIT-solr-2026-22022"},{"ecosystem":"Maven","fixed":["9.10.1"],"introduced":["5.3.0"],"last_affected":[],"package":"org.apache.solr:solr-core","purl":null,"source":"GHSA-qr3p-2xj2-q7hq"},{"ecosystem":"Maven","fixed":["9.10.1"],"introduced":["5.3.0"],"last_affected":[],"package":"org.apache.solr:solr-core","purl":"pkg:maven/org.apache.solr/solr-core","source":"GHSA-qr3p-2xj2-q7hq"}],"prev":{"headline":"Denial of service in Oracle GraalVM Enterprise Edition","id":"CVE-2026-22021"},"products":["Apache Solr"],"published":"2026-01-21","related":[{"cvss_score":7.5,"headline":"Apache Solr VelocityResponseWriter Plug-In Remote Code Execution","id":"CVE-2019-17558","kev_date_added":"2021-11-03","published":"2019-12-30"},{"cvss_score":7.2,"headline":"Apache Solr DataImportHandler Code Injection","id":"CVE-2019-0193","kev_date_added":"2021-12-10","published":"2019-08-01"},{"cvss_score":9.8,"headline":"Apache Solr: Authentication bypass possible using a fake URL Path ending","id":"CVE-2024-45216","kev_date_added":null,"published":"2024-10-16"},{"cvss_score":9.8,"headline":"Apache Solr information disclosure vulnerability through DataImportHandler","id":"CVE-2021-44548","kev_date_added":null,"published":"2021-12-23"},{"cvss_score":9.8,"headline":"SSRF vulnerability with the Replication handler","id":"CVE-2021-27905","kev_date_added":null,"published":"2021-04-13"},{"cvss_score":9.8,"headline":"Incorrect Authorization in Apache Solr","id":"CVE-2020-13957","kev_date_added":null,"published":"2020-10-13"},{"cvss_score":9.8,"headline":"Unrestricted upload of file with dangerous type in Apache Solr","id":"CVE-2019-12409","kev_date_added":null,"published":"2019-11-18"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-21","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass authorization rules to access restricted Solr APIs if specific permission configurations are used without the 'all' rule.","url":"https://insights.sbomify.com/CVE-2026-22022/"}