# CVE-2026-22022: Apache Solr: Unauthorized bypass of certain "predefined permission" rules in the RuleBasedAuthorizationPlugin

> Attackers can bypass authorization rules to access restricted Solr APIs if specific permission configurations are used without the 'all' rule.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 21 Jan 2026
- **Also known as:** BIT-solr-2026-22022, CLSA-2026-1792746136, GHSA-qr3p-2xj2-q7hq, MINI-p9wv-gmfx-ccg7, UBUNTU-CVE-2026-22022

## What is CVE-2026-22022?

CVE-2026-22022 is a high-severity missing authorization vulnerability in Apache Solr, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deployments of Apache Solr 5.3.0 through 9.10.0 that rely on Solr's "Rule Based Authorization Plugin" are vulnerable to allowing unauthorized access to certain Solr APIs, due to insufficiently strict input validation in those components.  Only deployments that meet all of the following criteria are impacted by this vulnerability:

  *  Use of Solr's "RuleBasedAuthorizationPlugin"
  *  A RuleBasedAuthorizationPlugin config (see security.json) that specifies multiple "roles"
  *  A RuleBasedAuthorizationPlugin permission list (see security.json) that uses one or more of the following pre-defined permission rules: "config-read", "config-edit", "schema-read", "metrics-read", or "security-read".
  *  A RuleBasedAuthorizationPlugin permission list that doesn't define the "all" pre-defined permission
  *  A networking setup that allows clients to make unfiltered network requests to Solr. (i.e. user-submitted HTTP/HTTPS requests reach Solr as-is, unmodified or restricted by any intervening proxy or gateway)

Users can mitigate this vulnerability by ensuring that their RuleBasedAuthorizationPlugin configuration specifies the "all" pre-defined permission and associates the permission with an "admin" or other privileged role.  Users can also upgrade to a Solr version outside of the impacted range, such as the recently released Solr 9.10.1.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-22022?

3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 5.3.0 | 9.10.1 |
| `org.apache.solr:solr-core` | Maven | From 5.3.0 | 9.10.1 |
| `solr` | Bitnami | From 5.3.0 | 9.10.1 |

Products: Apache Solr.

## How do I fix CVE-2026-22022?

Upgrade org.apache.solr:solr-core to 9.10.1 or later.

## Is CVE-2026-22022 being exploited?

There is no known exploitation of CVE-2026-22022 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22022 and fix it if it is affected.

What it is: CVE-2026-22022 is a high-severity missing authorization vulnerability in Apache Solr, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22022 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 5.3.0; fixed in 9.10.1
- org.apache.solr:solr-core (Maven): affected from 5.3.0; fixed in 9.10.1
- solr (Bitnami): affected from 5.3.0; fixed in 9.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22022/ (Markdown: https://insights.sbomify.com/CVE-2026-22022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22022
- OSV: https://osv.dev/vulnerability/CVE-2026-22022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22022/
Summaries are generated and may contain mistakes; the official description above is the record.
