# CVE-2026-22031: Fastify Middie Middleware Path Bypass

> Attackers can bypass middleware security checks on protected endpoints by using URL-encoded characters in the request path.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-cxrg-g7r8-w69p

## What is CVE-2026-22031?

CVE-2026-22031 is a high-severity vulnerability in fastify middie, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@fastify/middie is the plugin that adds middleware support on steroids to Fastify. A security vulnerability exists in @fastify/middie prior to version 9.1.0 where middleware registered with a specific path prefix can be bypassed using URL-encoded characters (e.g., `/%61dmin` instead of `/admin`). While the middleware engine fails to match the encoded path and skips execution, the underlying Fastify router correctly decodes the path and matches the route handler, allowing attackers to access protected endpoints without the middleware constraints. Version 9.1.0 fixes the issue.

Weakness: CWE-177 (Improper Handling of URL Encoding (Hex Encoding))

## Which versions are affected by CVE-2026-22031?

2 open source packages ship an affected version, including @fastify/middie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/middie` | npm | All versions | 9.1.0 |
| `@fastify/middie` | npm | All versions | 9.1.0 |

Products: Fastify Fastify\/Middie.

## How do I fix CVE-2026-22031?

Upgrade @fastify/middie to 9.1.0 or later.

## Is CVE-2026-22031 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22031 exists.

## Other vulnerabilities in fastify middie

- [CVE-2026-85184](https://insights.sbomify.com/CVE-2026-85184/): @fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target (critical 9.1)
- [CVE-2026-14198](https://insights.sbomify.com/CVE-2026-14198/): @fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values (critical 9.1)
- [CVE-2026-6270](https://insights.sbomify.com/CVE-2026-6270/): @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes (critical 9.1)
- [CVE-2026-2880](https://insights.sbomify.com/CVE-2026-2880/): @fastify/middie has an improper path normalization vulnerability (high 8.2)
- [CVE-2026-14181](https://insights.sbomify.com/CVE-2026-14181/): @fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22031 and fix it if it is affected.

What it is: CVE-2026-22031 is a high-severity vulnerability in fastify middie, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22031 exists.

Affected packages and fixed versions:
- @fastify/middie (npm): affected all versions; fixed in 9.1.0
- @fastify/middie (npm): affected all versions; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22031/ (Markdown: https://insights.sbomify.com/CVE-2026-22031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22031
- OSV: https://osv.dev/vulnerability/CVE-2026-22031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22031/
Summaries are generated and may contain mistakes; the official description above is the record.
