{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22034 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-22034 is a critical code injection vulnerability in jvoisin snuffleupagus, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22034 and fix it if it is affected.\n\nWhat it is: CVE-2026-22034 is a critical code injection vulnerability in jvoisin snuffleupagus, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22034 exists.\n\nAffected product: jvoisin snuffleupagus. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22034/ (Markdown: https://insights.sbomify.com/CVE-2026-22034/index.md)","id":"CVE-2026-22034","markdown":"https://insights.sbomify.com/CVE-2026-22034/index.md","name":"CVE-2026-22034","record":{"aliases":["DEBIAN-CVE-2026-22034","GHSA-c4ch-xw5p-2mvc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP security module","requires_auth":"none","summary":"Attackers can execute arbitrary PHP code via multipart POST requests if upload validation is enabled without the VLD extension.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"snuffleupagus","vendor":"jvoisin"}],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-636","name":"Not Failing Securely"}],"description":"Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Snuffleupagus vulnerable to RCE on instances with upload validation enabled but without the VLD package","id":"CVE-2026-22034","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"Greenshot Vulnerable to OS Command Injection via ExternalCommand Plugin","id":"CVE-2026-22035"},"packages":[],"prev":{"headline":"Label Studio vulnerable to full account takeover by chaining Stored XSS + IDOR in User Profile via custom_hotkeys field","id":"CVE-2026-22033"},"products":["snuffleupagus"],"published":"2026-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-08","vendors":["jvoisin"]},"summary":"Attackers can execute arbitrary PHP code via multipart POST requests if upload validation is enabled without the VLD extension.","url":"https://insights.sbomify.com/CVE-2026-22034/"}