# CVE-2026-22034: Snuffleupagus vulnerable to RCE on instances with upload validation enabled but without the VLD package

> Attackers can execute arbitrary PHP code via multipart POST requests if upload validation is enabled without the VLD extension.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** DEBIAN-CVE-2026-22034, GHSA-c4ch-xw5p-2mvc

## What is CVE-2026-22034?

CVE-2026-22034 is a critical code injection vulnerability in jvoisin snuffleupagus, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.

Weakness: CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2026-22034?

It affects 1 product.


Products: Jvoisin Snuffleupagus.

## How do I fix CVE-2026-22034?

Upgrade to a fixed version.

## Is CVE-2026-22034 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22034 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22034 and fix it if it is affected.

What it is: CVE-2026-22034 is a critical code injection vulnerability in jvoisin snuffleupagus, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22034 exists.

Affected product: jvoisin snuffleupagus. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22034/ (Markdown: https://insights.sbomify.com/CVE-2026-22034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22034
- OSV: https://osv.dev/vulnerability/CVE-2026-22034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22034/
Summaries are generated and may contain mistakes; the official description above is the record.
