{"answers":{"affected":"4 open source packages ship an affected version, including undici. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22036 in the wild and no public exploit code.","fix":"Upgrade undici to a fixed version for your release line: 6.23.0 or 7.18.2.","what":"CVE-2026-22036 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22036 and fix it if it is affected.\n\nWhat it is: CVE-2026-22036 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-22036 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- undici (npm): affected all versions; fixed in 6.23.0\n- undici (npm): affected all versions; fixed in 6.23.0\n- undici (npm): affected from 7.0.0; fixed in 7.18.2\n- undici (npm): affected from 7.0.0; fixed in 7.18.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22036/ (Markdown: https://insights.sbomify.com/CVE-2026-22036/index.md)","id":"CVE-2026-22036","markdown":"https://insights.sbomify.com/CVE-2026-22036/index.md","name":"CVE-2026-22036","record":{"aliases":["CLEANSTART-2026-MB67132","CLSA-2026-1775434874","CLSA-2026-1787000958","DEBIAN-CVE-2026-22036","ECHO-8428-9583-4bb5","GHSA-g9mf-h72j-4rw9","MINI-2m8j-f36q-pwq6","MINI-3q7w-78xq-pjfq","MINI-73qc-ffhh-2w8g","MINI-75qv-95qp-7pf5","MINI-86rq-wv6r-pmrx","MINI-hqw4-gm22-xmcf","MINI-jv7g-7xmr-m54h","MINI-mvjc-95pc-gp5p","ROOT-APP-NPM-CVE-2026-22036","UBUNTU-CVE-2026-22036","openSUSE-SU-2026:10075-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"A malicious server can cause resource exhaustion in Undici via unbounded decompression chains, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"undici","vendor":"nodejs"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Undici is an HTTP/1.1 client for Node.js. Prior to 7.18.0 and 6.23.0, the number of links in the decompression chain is unbounded and the default maxHeaderSize allows a malicious server to insert thousands compression steps leading to high CPU usage and excessive memory allocation. This vulnerability is fixed in 7.18.0 and 6.23.0.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Undici has an unbounded decompression chain in HTTP responses on Node.js Fetch API via Content-Encoding leads to resource exhaustion","id":"CVE-2026-22036","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:undici","products":["nodejs:undici"],"type":"denial_of_service","year":"2026"},"n_packages":5,"n_references":2,"next":{"headline":"@fastify/express vulnerable to Improper Handling of URL Encoding (Hex Encoding)","id":"CVE-2026-22037"},"packages":[{"ecosystem":"npm","fixed":["6.23.0"],"introduced":["0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-g9mf-h72j-4rw9"},{"ecosystem":"npm","fixed":["6.23.0"],"introduced":["0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-g9mf-h72j-4rw9"},{"ecosystem":"npm","fixed":["7.18.2"],"introduced":["7.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-g9mf-h72j-4rw9"},{"ecosystem":"npm","fixed":["7.18.2"],"introduced":["7.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-g9mf-h72j-4rw9"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["24.13.0-2.1"],"introduced":["0"],"last_affected":[],"package":"nodejs24","purl":"pkg:rpm/opensuse/nodejs24\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10075-1"}],"prev":{"headline":"Greenshot Vulnerable to OS Command Injection via ExternalCommand Plugin","id":"CVE-2026-22035"},"products":["undici"],"published":"2026-01-14","related":[{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake","id":"CVE-2026-109855","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unhandled error on excessive content-encodings","id":"CVE-2026-109869","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation","id":"CVE-2026-87018","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unrequested WebSocket subprotocol","id":"CVE-2026-19534","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via fragment count bypass","id":"CVE-2026-12151","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse","id":"CVE-2026-6734","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via cumulative fragment bypass","id":"CVE-2026-9675","kev_date_added":null,"published":"2026-06-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-22","vendors":["nodejs"]},"summary":"A malicious server can cause resource exhaustion in Undici via unbounded decompression chains, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-22036/"}