# CVE-2026-22036: Undici has an unbounded decompression chain in HTTP responses on Node.js Fetch API via Content-Encoding leads to resource exhaustion

> A malicious server can cause resource exhaustion in Undici via unbounded decompression chains, leading to denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** CLEANSTART-2026-MB67132, CLSA-2026-1775434874, CLSA-2026-1787000958, DEBIAN-CVE-2026-22036, ECHO-8428-9583-4bb5, GHSA-g9mf-h72j-4rw9, MINI-2m8j-f36q-pwq6, MINI-3q7w-78xq-pjfq, MINI-73qc-ffhh-2w8g, MINI-75qv-95qp-7pf5, MINI-86rq-wv6r-pmrx, MINI-hqw4-gm22-xmcf, MINI-jv7g-7xmr-m54h, MINI-mvjc-95pc-gp5p, ROOT-APP-NPM-CVE-2026-22036, UBUNTU-CVE-2026-22036, openSUSE-SU-2026:10075-1

## What is CVE-2026-22036?

CVE-2026-22036 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Undici is an HTTP/1.1 client for Node.js. Prior to 7.18.0 and 6.23.0, the number of links in the decompression chain is unbounded and the default maxHeaderSize allows a malicious server to insert thousands compression steps leading to high CPU usage and excessive memory allocation. This vulnerability is fixed in 7.18.0 and 6.23.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-22036?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 6.23.0 |
| `undici` | npm | All versions | 6.23.0 |
| `undici` | npm | From 7.0.0 | 7.18.2 |
| `undici` | npm | From 7.0.0 | 7.18.2 |
| `nodejs24` | openSUSE:Tumbleweed | All versions | 24.13.0-2.1 |

Products: Nodejs Undici.

## How do I fix CVE-2026-22036?

Upgrade undici to a fixed version for your release line: 6.23.0 or 7.18.2.

## Is CVE-2026-22036 being exploited?

There is no known exploitation of CVE-2026-22036 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22036 and fix it if it is affected.

What it is: CVE-2026-22036 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22036 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 6.23.0
- undici (npm): affected all versions; fixed in 6.23.0
- undici (npm): affected from 7.0.0; fixed in 7.18.2
- undici (npm): affected from 7.0.0; fixed in 7.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22036/ (Markdown: https://insights.sbomify.com/CVE-2026-22036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22036
- OSV: https://osv.dev/vulnerability/CVE-2026-22036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22036/
Summaries are generated and may contain mistakes; the official description above is the record.
