{"answers":{"affected":"2 open source packages ship an affected version, including @fastify/express.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22037 exists.","fix":"Upgrade @fastify/express to 4.0.3 or later.","what":"CVE-2026-22037 is a high-severity authentication bypass vulnerability in fastify-express, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22037 and fix it if it is affected.\n\nWhat it is: CVE-2026-22037 is a high-severity authentication bypass vulnerability in fastify-express, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22037 exists.\n\nAffected packages and fixed versions:\n- @fastify/express (npm): affected all versions; fixed in 4.0.3\n- @fastify/express (npm): affected all versions; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22037/ (Markdown: https://insights.sbomify.com/CVE-2026-22037/index.md)","id":"CVE-2026-22037","markdown":"https://insights.sbomify.com/CVE-2026-22037/index.md","name":"CVE-2026-22037","record":{"aliases":["GHSA-g6q3-96cp-5r5m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify Express plugin","requires_auth":"low_privilege","summary":"Attackers can bypass middleware security controls on protected endpoints by using URL-encoded characters in request paths.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"},{"id":"CWE-177","name":"Improper Handling of URL Encoding (Hex Encoding)"}],"description":"The @fastify/express plugin adds full Express compatibility to Fastify. A security vulnerability exists in @fastify/express prior to version 4.0.3 where middleware registered with a specific path prefix can be bypassed using URL-encoded characters (e.g., `/%61dmin` instead of `/admin`). While the middleware engine fails to match the encoded path and skips execution, the underlying Fastify router correctly decodes the path and matches the route handler, allowing attackers to access protected endpoints without the middleware constraints. The vulnerability is caused by how @fastify/express matches requests against registered middleware paths. This vulnerability is similar to, but differs from, CVE-2026-22031 because this is a different npm module with its own code. Version 4.0.3 of @fastify/express contains a patch fort the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@fastify/express vulnerable to Improper Handling of URL Encoding (Hex Encoding)","id":"CVE-2026-22037","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"AutoGPT's API Keys and Secrets Logged in Plaintext in Stagehand Integration Blocks","id":"CVE-2026-22038"},"packages":[{"ecosystem":"npm","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"@fastify/express","purl":null,"source":"GHSA-g6q3-96cp-5r5m"},{"ecosystem":"npm","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"@fastify/express","purl":"pkg:npm/%40fastify/express","source":"GHSA-g6q3-96cp-5r5m"}],"prev":{"headline":"Undici has an unbounded decompression chain in HTTP responses on Node.js Fetch API via Content-Encoding leads to resource exhaustion","id":"CVE-2026-22036"},"products":["fastify-express"],"published":"2026-01-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-20","vendors":["fastify"]},"summary":"Attackers can bypass middleware security controls on protected endpoints by using URL-encoded characters in request paths.","url":"https://insights.sbomify.com/CVE-2026-22037/"}