# CVE-2026-22041: loggingredactor converts non-string types to string types in logs

> An attacker can cause application crashes by triggering type errors in log formatting when non-string data is incorrectly converted to strings.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** GHSA-rvjx-cfjh-5mc9, PYSEC-2026-1582

## What is CVE-2026-22041?

CVE-2026-22041 is a low-severity vulnerability in armurox loggingredactor, published on 8 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Logging Redactor is a Python library designed to redact sensitive data in logs based on regex patterns and / or dictionary keys. Prior to version 0.0.6, non-string types are converted into string types, leading to type errors in %d conversions. The problem has been patched in version 0.0.6. No known workarounds are available.

Weakness: CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2026-22041?

3 open source packages ship an affected version, including loggingredactor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loggingredactor` | PyPI | All versions | 0.0.6 |
| `loggingredactor` | PyPI | All versions | 0.0.6 |
| `loggingredactor` | PyPI | All versions | 0.0.6 |

Products: Armurox Logging Redactor.

## How do I fix CVE-2026-22041?

Upgrade loggingredactor to 0.0.6 or later.

## Is CVE-2026-22041 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22041 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22041 and fix it if it is affected.

What it is: CVE-2026-22041 is a low-severity vulnerability in armurox loggingredactor, published on 8 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22041 exists.

Affected packages and fixed versions:
- loggingredactor (PyPI): affected all versions; fixed in 0.0.6
- loggingredactor (PyPI): affected all versions; fixed in 0.0.6
- loggingredactor (PyPI): affected all versions; fixed in 0.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22041/ (Markdown: https://insights.sbomify.com/CVE-2026-22041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22041
- OSV: https://osv.dev/vulnerability/CVE-2026-22041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22041/
Summaries are generated and may contain mistakes; the official description above is the record.
