CVE-2026-22044 GLPI is Vulnerable to Authenticated SQL Injection

Medium 6.5 Published Updated

An authenticated user can execute SQL injection attacks in GLPI, potentially reading or modifying database contents.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-22044?

CVE-2026-22044 is a medium-severity SQL injection vulnerability in Glpi-Project Glpi, published on 4 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GLPI is a free asset and IT management software package. From version 0.85 to before 10.0.23, an authenticated user can perform a SQL injection. This issue has been patched in version 10.0.23.

Weakness: CWE-89

Which versions are affected by CVE-2026-22044?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2026-22044?

No fix has been published for CVE-2026-22044 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-22044 being exploited?

There is no known exploitation of CVE-2026-22044 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-569q-j526-w385, UBUNTU-CVE-2026-22044.

Is CVE-2026-22044 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free