CVE-2026-22217 OpenClaw 2026.2.22 < 2026.2.23 - Arbitrary Binary Execution via $SHELL Environment Variable Trusted Prefix Fallback

Medium 5.8 Published Updated

Attackers can execute arbitrary binaries by manipulating the $SHELL environment variable in OpenClaw, leading to code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-22217?

CVE-2026-22217 is a medium-severity command injection vulnerability in Openclaw Openclaw, published on 18 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenClaw version 2026.2.22 prior to 2026.2.23 contains an arbitrary code execution vulnerability in shell-env that allows attackers to execute attacker-controlled binaries by exploiting trusted-prefix fallback logic for the $SHELL variable. An attacker can influence the $SHELL environment variable on systems with writable trusted-prefix directories such as /opt/homebrew/bin to execute arbitrary binaries in the OpenClaw process context.

Weakness: CWE-829

Which versions are affected by CVE-2026-22217?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.2.222026.2.23
openclaw npmFrom 2026.2.222026.2.23

Products include Openclaw Openclaw.

How do I fix CVE-2026-22217?

Upgrade openclaw to 2026.2.23 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-22217 being exploited?

There is no known exploitation of CVE-2026-22217 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-p4wh-cr8m-gm6c, MINI-8h45-x939-2fcp.

Is CVE-2026-22217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free