{"answers":{"affected":"1 open source package ship an affected version, including chainlit. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22218 exists.","fix":"Upgrade chainlit to 2.9.4 or later.","what":"CVE-2026-22218 is a high-severity path traversal vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22218 and fix it if it is affected.\n\nWhat it is: CVE-2026-22218 is a high-severity path traversal vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22218 exists.\n\nAffected packages and fixed versions:\n- chainlit (PyPI): affected all versions; fixed in 2.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22218/ (Markdown: https://insights.sbomify.com/CVE-2026-22218/index.md)","id":"CVE-2026-22218","markdown":"https://insights.sbomify.com/CVE-2026-22218/index.md","name":"CVE-2026-22218","record":{"aliases":["GHSA-gm79-2pvc-wc75","PYSEC-2026-598"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Chainlit web framework","requires_auth":"low_privilege","summary":"An authenticated attacker can read arbitrary files from the server by manipulating path values in the element update flow.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"chainlit","vendor":"chainlit"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Chainlit versions prior to 2.9.4 contain an arbitrary file read vulnerability in the /project/element update flow. An authenticated client can send a custom Element with a user-controlled path value, causing the server to copy the referenced file into the attacker’s session. The resulting element identifier (chainlitKey) can then be used to retrieve the file contents via /project/file/\u003cchainlitKey\u003e, allowing disclosure of any file readable by the Chainlit service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Chainlit \u003c 2.9.4 Arbitrary File Read via /project/element","id":"CVE-2026-22218","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"Chainlit \u003c 2.9.4 SQLAlchemy Data Layer SSRF via /project/element","id":"CVE-2026-22219"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.4"],"introduced":["0"],"last_affected":[],"package":"chainlit","purl":"pkg:pypi/chainlit","source":"PYSEC-2026-598"}],"prev":{"headline":"OpenClaw 2026.2.22 \u003c 2026.2.23 - Arbitrary Binary Execution via $SHELL Environment Variable Trusted Prefix Fallback","id":"CVE-2026-22217"},"products":["Chainlit"],"published":"2026-01-19","related":[{"cvss_score":8.3,"headline":"Chainlit \u003c 2.9.4 SQLAlchemy Data Layer SSRF via /project/element","id":"CVE-2026-22219","kev_date_added":null,"published":"2026-01-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["Chainlit"]},"summary":"An authenticated attacker can read arbitrary files from the server by manipulating path values in the element update flow.","url":"https://insights.sbomify.com/CVE-2026-22218/"}