# CVE-2026-22218: Chainlit < 2.9.4 Arbitrary File Read via /project/element

> An authenticated attacker can read arbitrary files from the server by manipulating path values in the element update flow.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-gm79-2pvc-wc75, PYSEC-2026-598

## What is CVE-2026-22218?

CVE-2026-22218 is a high-severity path traversal vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Chainlit versions prior to 2.9.4 contain an arbitrary file read vulnerability in the /project/element update flow. An authenticated client can send a custom Element with a user-controlled path value, causing the server to copy the referenced file into the attacker’s session. The resulting element identifier (chainlitKey) can then be used to retrieve the file contents via /project/file/<chainlitKey>, allowing disclosure of any file readable by the Chainlit service.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-22218?

1 open source package ship an affected version, including chainlit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainlit` | PyPI | All versions | 2.9.4 |

Products: Chainlit Chainlit.

## How do I fix CVE-2026-22218?

Upgrade chainlit to 2.9.4 or later.

## Is CVE-2026-22218 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22218 exists.

## Other vulnerabilities in Chainlit

- [CVE-2026-22219](https://insights.sbomify.com/CVE-2026-22219/): Chainlit < 2.9.4 SQLAlchemy Data Layer SSRF via /project/element (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22218 and fix it if it is affected.

What it is: CVE-2026-22218 is a high-severity path traversal vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22218 exists.

Affected packages and fixed versions:
- chainlit (PyPI): affected all versions; fixed in 2.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22218/ (Markdown: https://insights.sbomify.com/CVE-2026-22218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22218
- OSV: https://osv.dev/vulnerability/CVE-2026-22218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22218/
Summaries are generated and may contain mistakes; the official description above is the record.
