{"answers":{"affected":"3 open source packages ship an affected version, including chainlit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22219 in the wild and no public exploit code.","fix":"Upgrade chainlit to 2.9.4 or later.","what":"CVE-2026-22219 is a high-severity server-side request forgery vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22219 and fix it if it is affected.\n\nWhat it is: CVE-2026-22219 is a high-severity server-side request forgery vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-22219 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- chainlit (PyPI): affected all versions; fixed in 2.9.4\n- chainlit (PyPI): affected all versions; fixed in 2.9.4\n- chainlit (PyPI): affected all versions; fixed in 2.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22219/ (Markdown: https://insights.sbomify.com/CVE-2026-22219/index.md)","id":"CVE-2026-22219","markdown":"https://insights.sbomify.com/CVE-2026-22219/index.md","name":"CVE-2026-22219","record":{"aliases":["GHSA-2g59-m95p-pgfq","PYSEC-2026-1237"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Chainlit web framework","requires_auth":"low_privilege","summary":"Authenticated attackers can trigger SSRF in Chainlit's SQLAlchemy backend to access internal services and cloud metadata.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"chainlit","vendor":"chainlit"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Chainlit versions prior to 2.9.4 contain a server-side request forgery (SSRF) vulnerability in the /project/element update flow when configured with the SQLAlchemy data layer backend. An authenticated client can provide a user-controlled url value in an Element, which is fetched by the SQLAlchemy element creation logic using an outbound HTTP GET request. This allows an attacker to make arbitrary HTTP requests from the Chainlit server to internal network services or cloud metadata endpoints and store the retrieved responses via the configured storage provider.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Chainlit \u003c 2.9.4 SQLAlchemy Data Layer SSRF via /project/element","id":"CVE-2026-22219","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Improper Input Validation Leading to DoS on TP-Link Archer BE230","id":"CVE-2026-22220"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.4"],"introduced":["0"],"last_affected":[],"package":"chainlit","purl":null,"source":"GHSA-2g59-m95p-pgfq"},{"ecosystem":"PyPI","fixed":["2.9.4"],"introduced":["0"],"last_affected":[],"package":"chainlit","purl":"pkg:pypi/chainlit","source":"GHSA-2g59-m95p-pgfq"},{"ecosystem":"PyPI","fixed":["2.9.4"],"introduced":["0"],"last_affected":[],"package":"chainlit","purl":"pkg:pypi/chainlit","source":"PYSEC-2026-1237"}],"prev":{"headline":"Chainlit \u003c 2.9.4 Arbitrary File Read via /project/element","id":"CVE-2026-22218"},"products":["Chainlit"],"published":"2026-01-19","related":[{"cvss_score":7.1,"headline":"Chainlit \u003c 2.9.4 Arbitrary File Read via /project/element","id":"CVE-2026-22218","kev_date_added":null,"published":"2026-01-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["Chainlit"]},"summary":"Authenticated attackers can trigger SSRF in Chainlit's SQLAlchemy backend to access internal services and cloud metadata.","url":"https://insights.sbomify.com/CVE-2026-22219/"}