# CVE-2026-22219: Chainlit < 2.9.4 SQLAlchemy Data Layer SSRF via /project/element

> Authenticated attackers can trigger SSRF in Chainlit's SQLAlchemy backend to access internal services and cloud metadata.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-2g59-m95p-pgfq, PYSEC-2026-1237

## What is CVE-2026-22219?

CVE-2026-22219 is a high-severity server-side request forgery vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Chainlit versions prior to 2.9.4 contain a server-side request forgery (SSRF) vulnerability in the /project/element update flow when configured with the SQLAlchemy data layer backend. An authenticated client can provide a user-controlled url value in an Element, which is fetched by the SQLAlchemy element creation logic using an outbound HTTP GET request. This allows an attacker to make arbitrary HTTP requests from the Chainlit server to internal network services or cloud metadata endpoints and store the retrieved responses via the configured storage provider.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-22219?

3 open source packages ship an affected version, including chainlit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainlit` | PyPI | All versions | 2.9.4 |
| `chainlit` | PyPI | All versions | 2.9.4 |
| `chainlit` | PyPI | All versions | 2.9.4 |

Products: Chainlit Chainlit.

## How do I fix CVE-2026-22219?

Upgrade chainlit to 2.9.4 or later.

## Is CVE-2026-22219 being exploited?

There is no known exploitation of CVE-2026-22219 in the wild and no public exploit code.

## Other vulnerabilities in Chainlit

- [CVE-2026-22218](https://insights.sbomify.com/CVE-2026-22218/): Chainlit < 2.9.4 Arbitrary File Read via /project/element (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22219 and fix it if it is affected.

What it is: CVE-2026-22219 is a high-severity server-side request forgery vulnerability in Chainlit, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22219 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainlit (PyPI): affected all versions; fixed in 2.9.4
- chainlit (PyPI): affected all versions; fixed in 2.9.4
- chainlit (PyPI): affected all versions; fixed in 2.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22219/ (Markdown: https://insights.sbomify.com/CVE-2026-22219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22219
- OSV: https://osv.dev/vulnerability/CVE-2026-22219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22219/
Summaries are generated and may contain mistakes; the official description above is the record.
