# CVE-2026-22242: CoreShop Vulnerable to SQL Injection via Admin Reports

> An authenticated administrator can exploit a blind SQL injection vulnerability in CoreShop to extract confidential database contents.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** GHSA-ch7p-mpv4-4vg4

## What is CVE-2026-22242?

CVE-2026-22242 is a medium-severity SQL injection vulnerability in CoreShop, published on 8 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

CoreShop is a Pimcore enhanced eCommerce solution. Prior to version 4.1.8, a blind SQL injection vulnerability exists in the application that allows an authenticated administrator-level user to extract database contents using boolean-based or time-based techniques. The database account used by the application is read-only and non-DBA, limiting impact to confidential data disclosure only. No data modification or service disruption is possible. This issue has been patched in version 4.1.8.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-564 (Use of Hibernate with HQL/SQL Query String Containing External Input)

## Which versions are affected by CVE-2026-22242?

2 open source packages ship an affected version, including coreshop/core-shop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `coreshop/core-shop` | Packagist | All versions | 4.1.8 |
| `coreshop/core-shop` | Packagist | All versions | 4.1.8 |

Products: Coreshop Coreshop.

## How do I fix CVE-2026-22242?

Upgrade coreshop/core-shop to 4.1.8 or later.

## Is CVE-2026-22242 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22242 exists.

## Other vulnerabilities in CoreShop

- [CVE-2026-23959](https://insights.sbomify.com/CVE-2026-23959/): CoreShop Vulnerable to SQL Injection via Admin customer-company-modifier (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22242 and fix it if it is affected.

What it is: CVE-2026-22242 is a medium-severity SQL injection vulnerability in CoreShop, published on 8 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22242 exists.

Affected packages and fixed versions:
- coreshop/core-shop (Packagist): affected all versions; fixed in 4.1.8
- coreshop/core-shop (Packagist): affected all versions; fixed in 4.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22242/ (Markdown: https://insights.sbomify.com/CVE-2026-22242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22242
- OSV: https://osv.dev/vulnerability/CVE-2026-22242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22242/
Summaries are generated and may contain mistakes; the official description above is the record.
