# CVE-2026-22243: EGroupware has SQL Injection in Nextmatch Filter Processing

> Authenticated attackers can inject SQL commands via Nextmatch filter processing in EGroupware, allowing unauthorized database access and modification.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 28 Jan 2026
- **Also known as:** GHSA-rvxj-7f72-mhrx

## What is CVE-2026-22243?

CVE-2026-22243 is a high-severity SQL injection vulnerability in egroupware, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

EGroupware is a Web based groupware server written in PHP. A SQL Injection vulnerability exists in the core components of EGroupware prior to versions 23.1.20260113 and 26.0.20260113, specifically in the `Nextmatch` filter processing. The flaw allows authenticated attackers to inject arbitrary SQL commands into the `WHERE` clause of database queries. This is achieved by exploiting a PHP type juggling issue where JSON decoding converts numeric strings into integers, bypassing the `is_int()` security check used by the application. Versions 23.1.20260113 and 26.0.20260113 patch the vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-22243?

4 open source packages ship an affected version, including egroupware/egroupware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `egroupware/egroupware` | Packagist | All versions | 23.1.20260113 |
| `egroupware/egroupware` | Packagist | All versions | 23.1.20260113 |
| `egroupware/egroupware` | Packagist | From 26.0.20251208 | 26.0.20260113 |
| `egroupware/egroupware` | Packagist | From 26.0.20251208 | 26.0.20260113 |

Products: Egroupware Egroupware.

## How do I fix CVE-2026-22243?

Upgrade egroupware/egroupware to a fixed version for your release line: 23.1.20260113 or 26.0.20260113.

## Is CVE-2026-22243 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22243 exists.

Public exploit code:

- CVE-2026-22243 - EGroupware has SQL Injection in Nextmatch Filter Processing (github_poc): https://github.com/lukasz-rybak/CVE-2026-22243

## Other vulnerabilities in egroupware

- [CVE-2008-2041](https://insights.sbomify.com/CVE-2008-2041/): Code injection in n/a (critical 10.0)
- [CVE-2007-3154](https://insights.sbomify.com/CVE-2007-3154/): Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as used by eGroupWare before 1.2.107-2 and other packa (critical 10.0)
- [CVE-2007-3155](https://insights.sbomify.com/CVE-2007-3155/): Other in n/a (critical 10.0)
- [CVE-2014-2988](https://insights.sbomify.com/CVE-2014-2988/): Code injection in n/a (high 8.5)
- [CVE-2014-2027](https://insights.sbomify.com/CVE-2014-2027/): Code injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22243 and fix it if it is affected.

What it is: CVE-2026-22243 is a high-severity SQL injection vulnerability in egroupware, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22243 exists.

Affected packages and fixed versions:
- egroupware/egroupware (Packagist): affected all versions; fixed in 23.1.20260113
- egroupware/egroupware (Packagist): affected all versions; fixed in 23.1.20260113
- egroupware/egroupware (Packagist): affected from 26.0.20251208; fixed in 26.0.20260113
- egroupware/egroupware (Packagist): affected from 26.0.20251208; fixed in 26.0.20260113

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22243/ (Markdown: https://insights.sbomify.com/CVE-2026-22243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22243
- OSV: https://osv.dev/vulnerability/CVE-2026-22243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22243/
Summaries are generated and may contain mistakes; the official description above is the record.
