CVE-2026-22247 GLPI is Vulnerable to SSRF via Webhooks

Medium 4.1 Published Updated

An administrator can exploit the Webhook feature to perform Server-Side Request Forgery attacks, potentially accessing internal resources.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-22247?

CVE-2026-22247 is a medium-severity server-side request forgery vulnerability in Glpi-Project Glpi, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GLPI is a free asset and IT management software package. From version 11.0.0 to before 11.0.5, a GLPI administrator can perform SSRF request through the Webhook feature. This issue has been patched in version 11.0.5.

Weakness: CWE-918

Which versions are affected by CVE-2026-22247?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2026-22247?

No fix has been published for CVE-2026-22247 yet. Limit exposure of the affected software until one is available.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-22247 being exploited?

There is no known exploitation of CVE-2026-22247 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-f6f6-v3qr-9p5x, UBUNTU-CVE-2026-22247.

Is CVE-2026-22247 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free