{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22248 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-22248 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-22248 is a high-severity unsafe deserialization vulnerability in glpi-project glpi, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22248 and fix it if it is affected.\n\nWhat it is: CVE-2026-22248 is a high-severity unsafe deserialization vulnerability in glpi-project glpi, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-22248 in the wild and no public exploit code.\n\nAffected product: glpi-project glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22248/ (Markdown: https://insights.sbomify.com/CVE-2026-22248/index.md)","id":"CVE-2026-22248","markdown":"https://insights.sbomify.com/CVE-2026-22248/index.md","name":"CVE-2026-22248","record":{"aliases":["GHSA-c9q3-mcxq-9vr4","UBUNTU-CVE-2026-22248"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"IT asset management","requires_auth":"high_privilege","summary":"Authenticated technicians can achieve remote code execution in GLPI by uploading malicious files that trigger unsafe PHP instantiation.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glpi","vendor":"teclib-edition"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. From 11.0.0 to before 11.0.5, an authenticated technician user can upload a malicious file and trigger its execution through an unsafe PHP instantiation. This vulnerability is fixed in 11.0.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"GLPI affected by Remote Code Execution via malicious upload","id":"CVE-2026-22248","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Docmost affected by an Arbitrary File Write via Zip Import Feature (ZipSlip)","id":"CVE-2026-22249"},"packages":[],"prev":{"headline":"GLPI is Vulnerable to SSRF via Webhooks","id":"CVE-2026-22247"},"products":["glpi"],"published":"2026-03-11","related":[{"cvss_score":6.5,"headline":"GLPI Vulnerable to Authenticated SQL Injection","id":"CVE-2026-25936","kev_date_added":null,"published":"2026-03-17"},{"cvss_score":6.5,"headline":"GLPI has a MFA bypass","id":"CVE-2026-25937","kev_date_added":null,"published":"2026-03-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-12","vendors":["glpi-project"]},"summary":"Authenticated technicians can achieve remote code execution in GLPI by uploading malicious files that trigger unsafe PHP instantiation.","url":"https://insights.sbomify.com/CVE-2026-22248/"}