# CVE-2026-22248: GLPI affected by Remote Code Execution via malicious upload

> Authenticated technicians can achieve remote code execution in GLPI by uploading malicious files that trigger unsafe PHP instantiation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-c9q3-mcxq-9vr4, UBUNTU-CVE-2026-22248

## What is CVE-2026-22248?

CVE-2026-22248 is a high-severity unsafe deserialization vulnerability in glpi-project glpi, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. From 11.0.0 to before 11.0.5, an authenticated technician user can upload a malicious file and trigger its execution through an unsafe PHP instantiation. This vulnerability is fixed in 11.0.5.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-22248?

It affects 1 product.


Products: Teclib-Edition Glpi.

## How do I fix CVE-2026-22248?

No fix has been published for CVE-2026-22248 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-22248 being exploited?

There is no known exploitation of CVE-2026-22248 in the wild and no public exploit code.

## Other vulnerabilities in glpi-project glpi

- [CVE-2026-25936](https://insights.sbomify.com/CVE-2026-25936/): GLPI Vulnerable to Authenticated SQL Injection (medium 6.5)
- [CVE-2026-25937](https://insights.sbomify.com/CVE-2026-25937/): GLPI has a MFA bypass (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22248 and fix it if it is affected.

What it is: CVE-2026-22248 is a high-severity unsafe deserialization vulnerability in glpi-project glpi, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22248 in the wild and no public exploit code.

Affected product: glpi-project glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22248/ (Markdown: https://insights.sbomify.com/CVE-2026-22248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22248
- OSV: https://osv.dev/vulnerability/CVE-2026-22248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22248/
Summaries are generated and may contain mistakes; the official description above is the record.
