{"answers":{"affected":"3 open source packages ship an affected version, including wlc. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22250 in the wild and no public exploit code.","fix":"Upgrade wlc to 1.17.0 or later.","what":"CVE-2026-22250 is a low-severity vulnerability in WeblateOrg wlc, published on 12 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-22250 and fix it if it is affected.\n\nWhat it is: CVE-2026-22250 is a low-severity vulnerability in WeblateOrg wlc, published on 12 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-22250 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wlc (PyPI): affected all versions; fixed in 1.17.0\n- wlc (PyPI): affected all versions; fixed in 1.17.0\n- wlc (PyPI): affected all versions; fixed in 1.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22250/ (Markdown: https://insights.sbomify.com/CVE-2026-22250/index.md)","id":"CVE-2026-22250","markdown":"https://insights.sbomify.com/CVE-2026-22250/index.md","name":"CVE-2026-22250","record":{"aliases":["DEBIAN-CVE-2026-22250","GHSA-2mmv-7rrp-g8xh","PYSEC-2026-2051","UBUNTU-CVE-2026-22250"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Weblate CLI client","requires_auth":"low_privilege","summary":"Attackers can bypass SSL verification in the Weblate command-line client, potentially enabling man-in-the-middle attacks against API communications.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wlc","vendor":"weblate"}],"cvss":{"score":2.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"wlc can skip SSL verification","id":"CVE-2026-22250","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"wlc may leak API keys due to an insecure API key configuration","id":"CVE-2026-22251"},"packages":[{"ecosystem":"PyPI","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":null,"source":"GHSA-2mmv-7rrp-g8xh"},{"ecosystem":"PyPI","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":"pkg:pypi/wlc","source":"GHSA-2mmv-7rrp-g8xh"},{"ecosystem":"PyPI","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":"pkg:pypi/wlc","source":"PYSEC-2026-2051"}],"prev":{"headline":"Docmost affected by an Arbitrary File Write via Zip Import Feature (ZipSlip)","id":"CVE-2026-22249"},"products":["wlc"],"published":"2026-01-12","related":[{"cvss_score":8.1,"headline":"wlc Path traversal: Unsanitized API slugs in download command","id":"CVE-2026-23535","kev_date_added":null,"published":"2026-01-16"},{"cvss_score":5.3,"headline":"wlc may leak API keys due to an insecure API key configuration","id":"CVE-2026-22251","kev_date_added":null,"published":"2026-01-12"},{"cvss_score":5.1,"headline":"wlc: print_html outputs API data without HTML escaping, enabling stored XSS","id":"CVE-2026-42150","kev_date_added":null,"published":"2026-05-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-12","vendors":["WeblateOrg"]},"summary":"Attackers can bypass SSL verification in the Weblate command-line client, potentially enabling man-in-the-middle attacks against API communications.","url":"https://insights.sbomify.com/CVE-2026-22250/"}