# CVE-2026-22250: wlc can skip SSL verification

> Attackers can bypass SSL verification in the Weblate command-line client, potentially enabling man-in-the-middle attacks against API communications.

- **Severity:** Low 2.5 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** DEBIAN-CVE-2026-22250, GHSA-2mmv-7rrp-g8xh, PYSEC-2026-2051, UBUNTU-CVE-2026-22250

## What is CVE-2026-22250?

CVE-2026-22250 is a low-severity vulnerability in WeblateOrg wlc, published on 12 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-22250?

3 open source packages ship an affected version, including wlc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wlc` | PyPI | All versions | 1.17.0 |
| `wlc` | PyPI | All versions | 1.17.0 |
| `wlc` | PyPI | All versions | 1.17.0 |

Products: Weblate Wlc.

## How do I fix CVE-2026-22250?

Upgrade wlc to 1.17.0 or later.

## Is CVE-2026-22250 being exploited?

There is no known exploitation of CVE-2026-22250 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg wlc

- [CVE-2026-23535](https://insights.sbomify.com/CVE-2026-23535/): wlc Path traversal: Unsanitized API slugs in download command (high 8.1)
- [CVE-2026-22251](https://insights.sbomify.com/CVE-2026-22251/): wlc may leak API keys due to an insecure API key configuration (medium 5.3)
- [CVE-2026-42150](https://insights.sbomify.com/CVE-2026-42150/): wlc: print_html outputs API data without HTML escaping, enabling stored XSS (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22250 and fix it if it is affected.

What it is: CVE-2026-22250 is a low-severity vulnerability in WeblateOrg wlc, published on 12 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-22250 in the wild and no public exploit code.

Affected packages and fixed versions:
- wlc (PyPI): affected all versions; fixed in 1.17.0
- wlc (PyPI): affected all versions; fixed in 1.17.0
- wlc (PyPI): affected all versions; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22250/ (Markdown: https://insights.sbomify.com/CVE-2026-22250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22250
- OSV: https://osv.dev/vulnerability/CVE-2026-22250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22250/
Summaries are generated and may contain mistakes; the official description above is the record.
