# CVE-2026-22251: wlc may leak API keys due to an insecure API key configuration


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** DEBIAN-CVE-2026-22251, GHSA-9rp8-h4g8-8766, PYSEC-2026-2052, UBUNTU-CVE-2026-22251

## What is CVE-2026-22251?

CVE-2026-22251 is a medium-severity vulnerability in WeblateOrg wlc, published on 12 Jan 2026. 

### Official description

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, wlc supported providing unscoped API keys in the setting. This practice was discouraged for years, but the code was never removed. This might cause the API key to be leaked to different servers.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-22251?

3 open source packages ship an affected version, including wlc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wlc` | PyPI | All versions | 1.17.0 |
| `wlc` | PyPI | All versions | 1.17.0 |
| `wlc` | PyPI | All versions | 1.17.0 |

Products: Weblate Wlc.

## How do I fix CVE-2026-22251?

Upgrade wlc to 1.17.0 or later.

## Is CVE-2026-22251 being exploited?

There is no known exploitation of CVE-2026-22251 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg wlc

- [CVE-2026-23535](https://insights.sbomify.com/CVE-2026-23535/): wlc Path traversal: Unsanitized API slugs in download command (high 8.1)
- [CVE-2026-42150](https://insights.sbomify.com/CVE-2026-42150/): wlc: print_html outputs API data without HTML escaping, enabling stored XSS (medium 5.1)
- [CVE-2026-22250](https://insights.sbomify.com/CVE-2026-22250/): wlc can skip SSL verification (low 2.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22251 and fix it if it is affected.

What it is: CVE-2026-22251 is a medium-severity vulnerability in WeblateOrg wlc, published on 12 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2026-22251 in the wild and no public exploit code.

Affected packages and fixed versions:
- wlc (PyPI): affected all versions; fixed in 1.17.0
- wlc (PyPI): affected all versions; fixed in 1.17.0
- wlc (PyPI): affected all versions; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22251/ (Markdown: https://insights.sbomify.com/CVE-2026-22251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22251
- OSV: https://osv.dev/vulnerability/CVE-2026-22251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22251/
Summaries are generated and may contain mistakes; the official description above is the record.
