# CVE-2026-22252: LibreChat MCP Stdio Remote Command Execution

> Authenticated users can execute arbitrary shell commands as root via the MCP stdio transport due to lack of input validation.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-cxhj-j78r-p88f

## What is CVE-2026-22252?

CVE-2026-22252 is a critical command injection vulnerability in Librechat Librechat, published on 12 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LibreChat is a ChatGPT clone with additional features. Prior to v0.8.2-rc2, LibreChat's MCP stdio transport accepts arbitrary commands without validation, allowing any authenticated user to execute shell commands as root inside the container through a single API request. This vulnerability is fixed in v0.8.2-rc2.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-22252?

It affects 1 product.


Products: Librechat Librechat.

## How do I fix CVE-2026-22252?

No fix has been published for CVE-2026-22252 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-22252 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22252 exists.

## Other vulnerabilities in Librechat Librechat

- [CVE-2026-32625](https://insights.sbomify.com/CVE-2026-32625/): LibreChat Exfiltrates Server Secrets via MCP Server URL Injection (critical 9.6)
- [CVE-2024-11167](https://insights.sbomify.com/CVE-2024-11167/): Improper Access Control in danny-avila/librechat (critical 9.4)
- [CVE-2025-69222](https://insights.sbomify.com/CVE-2025-69222/): LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions (critical 9.1)
- [CVE-2024-41704](https://insights.sbomify.com/CVE-2024-41704/): Path traversal in n/a (critical 9.1)
- [CVE-2024-11170](https://insights.sbomify.com/CVE-2024-11170/): Path Traversal in danny-avila/librechat (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22252 and fix it if it is affected.

What it is: CVE-2026-22252 is a critical command injection vulnerability in Librechat Librechat, published on 12 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22252 exists.

Affected product: Librechat Librechat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22252/ (Markdown: https://insights.sbomify.com/CVE-2026-22252/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22252
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22252
- OSV: https://osv.dev/vulnerability/CVE-2026-22252

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22252/
Summaries are generated and may contain mistakes; the official description above is the record.
