CVE-2026-22444 Apache Solr: Insufficient file-access checking in standalone core-creation requests
Attackers can bypass file access restrictions to read unauthorized files or NTLM hashes via the core creation API in standalone Solr deployments.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-22444?
CVE-2026-22444 is a high-severity path traversal vulnerability in Apache Solr, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The "create core" API of Apache Solr 8.6 through 9.10.0 lacks sufficient input validation on some API parameters, which can cause Solr to check the existence of and attempt to read file-system paths that should be disallowed by Solr's "allowPaths" security setting https://https://solr.apache.org/guide/solr/latest/configuration-guide/configuring-solr-xml.html#the-solr-element . These read-only accesses can allow users to create cores using unexpected configsets if any are accessible via the filesystem. On Windows systems configured to allow UNC paths this can additionally cause disclosure of NTLM "user" hashes.
Solr deployments are subject to this vulnerability if they meet the following criteria: * Solr is running in its "standalone" mode. * Solr's "allowPath" setting is being used to restrict file access to certain directories. * Solr's "create core" API is exposed and accessible to untrusted users. This can happen if Solr's RuleBasedAuthorizationPlugin https://solr.apache.org/guide/solr/latest/deployment-guide/rule-based-authorization-plugin.html is disabled, or if it is enabled but the "core-admin-edit" predefined permission (or an equivalent custom permission) is given to low-trust (i.e. non-admin) user roles.
Users can mitigate this by enabling Solr's RuleBasedAuthorizationPlugin (if disabled) and configuring a permission-list that prevents untrusted users from creating new Solr cores. Users should also upgrade to Apache Solr 9.10.1 or greater, which contain fixes for this issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-22444?
3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.solr:solr-core Maven | From 8.6.0 | 9.10.1 |
org.apache.solr:solr-core Maven | From 8.6.0 | 9.10.1 |
solr Bitnami | From 8.6.0 | 9.10.1 |
Products include Apache Solr.
How do I fix CVE-2026-22444?
Upgrade org.apache.solr:solr-core to 9.10.1 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-22444 being exploited?
There is no known exploitation of CVE-2026-22444 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Apache Solr
- CVE-2019-17558 Apache Solr VelocityResponseWriter Plug-In Remote Code Execution
- CVE-2019-0193 Apache Solr DataImportHandler Code Injection
- CVE-2024-45216 Apache Solr: Authentication bypass possible using a fake URL Path ending
- CVE-2021-44548 Apache Solr information disclosure vulnerability through DataImportHandler
- CVE-2021-27905 SSRF vulnerability with the Replication handler
Sources
Also known as BIT-solr-2026-22444, GHSA-vc2w-4v3p-2mqw, MINI-3vjv-3w4c-6vp5, UBUNTU-CVE-2026-22444.