# CVE-2026-22444: Apache Solr: Insufficient file-access checking in standalone core-creation requests

> Attackers can bypass file access restrictions to read unauthorized files or NTLM hashes via the core creation API in standalone Solr deployments.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 21 Jan 2026
- **Also known as:** BIT-solr-2026-22444, GHSA-vc2w-4v3p-2mqw, MINI-3vjv-3w4c-6vp5, UBUNTU-CVE-2026-22444

## What is CVE-2026-22444?

CVE-2026-22444 is a high-severity path traversal vulnerability in Apache Solr, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The "create core" API of Apache Solr 8.6 through 9.10.0 lacks sufficient input validation on some API parameters, which can cause Solr to check the existence of and attempt to read file-system paths that should be disallowed by Solr's  "allowPaths" security setting https://https://solr.apache.org/guide/solr/latest/configuration-guide/configuring-solr-xml.html#the-solr-element .  These read-only accesses can allow users to create cores using unexpected configsets if any are accessible via the filesystem.  On Windows systems configured to allow UNC paths this can additionally cause disclosure of NTLM "user" hashes. 

Solr deployments are subject to this vulnerability if they meet the following criteria:
  *  Solr is running in its "standalone" mode.
  *  Solr's "allowPath" setting is being used to restrict file access to certain directories.
  *  Solr's "create core" API is exposed and accessible to untrusted users.  This can happen if Solr's  RuleBasedAuthorizationPlugin https://solr.apache.org/guide/solr/latest/deployment-guide/rule-based-authorization-plugin.html  is disabled, or if it is enabled but the "core-admin-edit" predefined permission (or an equivalent custom permission) is given to low-trust (i.e. non-admin) user roles.

Users can mitigate this by enabling Solr's RuleBasedAuthorizationPlugin (if disabled) and configuring a permission-list that prevents untrusted users from creating new Solr cores.  Users should also upgrade to Apache Solr 9.10.1 or greater, which contain fixes for this issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-22444?

3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 8.6.0 | 9.10.1 |
| `org.apache.solr:solr-core` | Maven | From 8.6.0 | 9.10.1 |
| `solr` | Bitnami | From 8.6.0 | 9.10.1 |

Products: Apache Solr.

## How do I fix CVE-2026-22444?

Upgrade org.apache.solr:solr-core to 9.10.1 or later.

## Is CVE-2026-22444 being exploited?

There is no known exploitation of CVE-2026-22444 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2026-22444: Apache Solr 8.6-9.10.0 Windows standalone mode RCE/NTLM hash disclosure (github_poc): https://github.com/dptsec/CVE-2026-22444
- CVE-2026-22444 是一个影响 Apache Solr 的安全漏洞，于 2026 年 1 月 20 日左右公开披露。该漏洞源于 Apache Solr 的 "create core" API 在某些 API 参数上的输入验证不足（CWE-20: Improper Input Validation），允许攻击者在 Solr 运行于 "standalone" 模式时绕过安全规则，可能导致数据泄露、远程代码执行 (RCE) 或 NTLM 哈希披露。 (github_poc): https://github.com/bfdfhdsfdd-crypto/CVE-2026-22444

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22444 and fix it if it is affected.

What it is: CVE-2026-22444 is a high-severity path traversal vulnerability in Apache Solr, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22444 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 8.6.0; fixed in 9.10.1
- org.apache.solr:solr-core (Maven): affected from 8.6.0; fixed in 9.10.1
- solr (Bitnami): affected from 8.6.0; fixed in 9.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22444/ (Markdown: https://insights.sbomify.com/CVE-2026-22444/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22444
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22444
- OSV: https://osv.dev/vulnerability/CVE-2026-22444

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22444/
Summaries are generated and may contain mistakes; the official description above is the record.
