CVE-2026-22545 Password Change Bypass via Auth Switch Endpoint
Authenticated attackers can bypass password confirmation by falsely claiming a different auth provider, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-22545?
CVE-2026-22545 is a low-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.11.x <= 10.11.10 fail to validate user's authentication method when processing account auth type switch which allows an authenticated attacker to change account password without confirmation via falsely claiming a different auth provider.. Mattermost Advisory ID: MMSA-2026-00583
Weakness: CWE-863
Which versions are affected by CVE-2026-22545?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260127144908-ced9a56e3988 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260127144908-ced9a56e3988 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1+incompatible | 10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
8 more packages
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260127144908-ced9a56e3988 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260127144908-ced9a56e3988 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260127144908-ced9a56e3988 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-22545?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20260127144908-ced9a56e3988, 10.11.11, 10.11.11+incompatible or 11.2.3+incompatible.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-22545 being exploited?
There is no known exploitation of CVE-2026-22545 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-rv67-7w2g-7976, GO-2026-4786.