# CVE-2026-22551: [Eclipse Theia] Data Exfiltration via Markdown Image Rendering in AI Chat


- **Severity:** Medium 6.7 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-qwjm-9c66-w4q4, UBUNTU-CVE-2026-22551

## What is CVE-2026-22551?

CVE-2026-22551 is a medium-severity vulnerability in Eclipse Theia, published on 18 Jun 2026. 

### Official description

In Eclipse Theia versions prior to 1.71.0, the AI chat rendered Markdown image tags from AI responses, triggering HTTP requests to arbitrary external URLs without restriction. Combined with prompt injection in a malicious workspace, an attacker could induce the AI agent to construct image URLs encoding sensitive information from the workspace or conversation context, exfiltrating it to attacker-controlled servers. The workspace trust enforcement introduced in v1.71.0 mitigates the documented attack chain by disabling AI features in untrusted workspaces.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-22551?

14 open source packages ship an affected version, including @theia/ai-chat, @theia/ai-chat-ui and @theia/ai-claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@theia/ai-chat` | npm | All versions | 1.71.0 |
| `@theia/ai-chat` | npm | All versions | 1.71.0 |
| `@theia/ai-chat-ui` | npm | All versions | 1.71.0 |
| `@theia/ai-chat-ui` | npm | All versions | 1.71.0 |
| `@theia/ai-claude-code` | npm | All versions | 1.71.0 |
| `@theia/ai-claude-code` | npm | All versions | 1.71.0 |
| `@theia/ai-code-completion` | npm | All versions | 1.71.0 |
| `@theia/ai-code-completion` | npm | All versions | 1.71.0 |
| `@theia/ai-core` | npm | All versions | 1.71.0 |
| `@theia/ai-core` | npm | All versions | 1.71.0 |
| `@theia/ai-editor` | npm | All versions | 1.71.0 |
| `@theia/ai-editor` | npm | All versions | 1.71.0 |
| `@theia/ai-ide` | npm | All versions | 1.71.0 |
| `@theia/ai-ide` | npm | All versions | 1.71.0 |

Products: Eclipse Theia.

## How do I fix CVE-2026-22551?

Upgrade @theia/ai-chat to 1.71.0 or later.

## Is CVE-2026-22551 being exploited?

There is no known exploitation of CVE-2026-22551 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Theia

- [CVE-2021-34436](https://insights.sbomify.com/CVE-2021-34436/): XML external entity in Eclipse Theia (critical 9.8)
- [CVE-2020-27224](https://insights.sbomify.com/CVE-2020-27224/): Cross-site Scripting (XSS) in Eclipse Theia (critical 9.6)
- [CVE-2026-60009](https://insights.sbomify.com/CVE-2026-60009/): File upload in Eclipse Theia (high 8.8)
- [CVE-2021-34435](https://insights.sbomify.com/CVE-2021-34435/): Remote code execution in Eclipse Theia (high 8.8)
- [CVE-2026-44688](https://insights.sbomify.com/CVE-2026-44688/): [Eclipse Theia] Indirect Prompt Injection via Adversarial Workspace File and Directory Names in AI Chat (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22551 and fix it if it is affected.

What it is: CVE-2026-22551 is a medium-severity vulnerability in Eclipse Theia, published on 18 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-22551 in the wild and no public exploit code.

Affected packages and fixed versions:
- @theia/ai-chat (npm): affected all versions; fixed in 1.71.0
- @theia/ai-chat (npm): affected all versions; fixed in 1.71.0
- @theia/ai-chat-ui (npm): affected all versions; fixed in 1.71.0
- @theia/ai-chat-ui (npm): affected all versions; fixed in 1.71.0
- @theia/ai-claude-code (npm): affected all versions; fixed in 1.71.0
- @theia/ai-claude-code (npm): affected all versions; fixed in 1.71.0
- @theia/ai-code-completion (npm): affected all versions; fixed in 1.71.0
- @theia/ai-code-completion (npm): affected all versions; fixed in 1.71.0
- @theia/ai-core (npm): affected all versions; fixed in 1.71.0
- @theia/ai-core (npm): affected all versions; fixed in 1.71.0
- @theia/ai-editor (npm): affected all versions; fixed in 1.71.0
- @theia/ai-editor (npm): affected all versions; fixed in 1.71.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22551/ (Markdown: https://insights.sbomify.com/CVE-2026-22551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22551
- OSV: https://osv.dev/vulnerability/CVE-2026-22551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22551/
Summaries are generated and may contain mistakes; the official description above is the record.
