# CVE-2026-22584: Salesforce Uni2TS has a Code Injection vulnerability

> Attackers can execute arbitrary code via improper control of code generation in the Salesforce Uni2TS library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-7x99-8x99-xc54, PYSEC-2026-557

## What is CVE-2026-22584?

CVE-2026-22584 is a critical code injection vulnerability in Salesforce Uni2TS, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Control of Generation of Code ('Code Injection') vulnerability in Salesforce Uni2TS on MacOS, Windows, Linux allows Leverage Executable Code in Non-Executable Files.This issue affects Uni2TS: through 1.2.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-22584?

3 open source packages ship an affected version, including uni2ts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uni2ts` | PyPI | All versions | 2.0.0 |
| `uni2ts` | PyPI | All versions | 2.0.0 |
| `uni2ts` | PyPI | All versions | 2.0.0 |

Products: Salesforce Uni2ts.

## How do I fix CVE-2026-22584?

Upgrade uni2ts to 2.0.0 or later.

## Is CVE-2026-22584 being exploited?

There is no known exploitation of CVE-2026-22584 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22584 and fix it if it is affected.

What it is: CVE-2026-22584 is a critical code injection vulnerability in Salesforce Uni2TS, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22584 in the wild and no public exploit code.

Affected packages and fixed versions:
- uni2ts (PyPI): affected all versions; fixed in 2.0.0
- uni2ts (PyPI): affected all versions; fixed in 2.0.0
- uni2ts (PyPI): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22584/ (Markdown: https://insights.sbomify.com/CVE-2026-22584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22584
- OSV: https://osv.dev/vulnerability/CVE-2026-22584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22584/
Summaries are generated and may contain mistakes; the official description above is the record.
