CVE-2026-22588 Spree API has Authenticated Insecure Direct Object Reference (IDOR) via Order Modification

Medium 6.5 Published Updated

Authenticated attackers can read other users' address information by manipulating order modification requests in the Spree e-commerce platform.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-22588?

CVE-2026-22588 is a medium-severity missing authorization vulnerability in spree, published on 8 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Spree is an open source e-commerce solution built with Ruby on Rails. Prior to versions 4.10.2, 5.0.7, 5.1.9, and 5.2.5, an Authenticated Insecure Direct Object Reference (IDOR) vulnerability was identified that allows an authenticated user to retrieve other users’ address information by modifying an existing order. By editing an order they legitimately own and manipulating address identifiers in the request, the backend server accepts and processes references to addresses belonging to other users, subsequently associating those addresses with the attacker’s order and returning them in the response. This issue has been patched in versions 4.10.2, 5.0.7, 5.1.9, and 5.2.5.

Weakness: CWE-639

Which versions are affected by CVE-2026-22588?

8 open source packages ship an affected version, including spree_api. It affects 1 product.

PackageAffectedFixed in
spree_api RubyGemsFrom 3.7.04.10.2
spree_api RubyGemsFrom 3.7.04.10.2
spree_api RubyGemsFrom 5.0.05.0.7
spree_api RubyGemsFrom 5.0.05.0.7
spree_api RubyGemsFrom 5.1.05.1.9
spree_api RubyGemsFrom 5.1.05.1.9
2 more packages
spree_api RubyGemsFrom 5.2.05.2.5
spree_api RubyGemsFrom 5.2.05.2.5

Products include Spreecommerce Spree.

How do I fix CVE-2026-22588?

Upgrade spree_api to a fixed version for your release line: 4.10.2, 5.0.7, 5.1.9 or 5.2.5.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-22588 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22588 exists.

Sources

Also known as GHSA-g268-72p7-9j6j.

Is CVE-2026-22588 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free