# CVE-2026-22589: Spree API has Unauthenticated IDOR - Guest Address

> Unauthenticated attackers can access guest address information in Spree e-commerce due to missing authorization checks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-3ghg-3787-w2xr

## What is CVE-2026-22589?

CVE-2026-22589 is a high-severity missing authorization vulnerability in spree, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spree is an open source e-commerce solution built with Ruby on Rails. Prior to versions 4.10.2, 5.0.7, 5.1.9, and 5.2.5, an Unauthenticated Insecure Direct Object Reference (IDOR) vulnerability was identified that allows an unauthenticated attacker to access guest address information without supplying valid credentials or session cookies. This issue has been patched in versions 4.10.2, 5.0.7, 5.1.9, and 5.2.5.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-22589?

8 open source packages ship an affected version, including spree_core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spree_core` | RubyGems | From 4.0.0 | 4.10.2 |
| `spree_core` | RubyGems | From 4.0.0 | 4.10.2 |
| `spree_core` | RubyGems | From 5.0.0 | 5.0.7 |
| `spree_core` | RubyGems | From 5.0.0 | 5.0.7 |
| `spree_core` | RubyGems | From 5.1.0 | 5.1.9 |
| `spree_core` | RubyGems | From 5.1.0 | 5.1.9 |
| `spree_core` | RubyGems | From 5.2.0 | 5.2.5 |
| `spree_core` | RubyGems | From 5.2.0 | 5.2.5 |

Products: Spreecommerce Spree.

## How do I fix CVE-2026-22589?

Upgrade spree_core to a fixed version for your release line: 4.10.2, 5.0.7, 5.1.9 or 5.2.5.

## Is CVE-2026-22589 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22589 exists.

## Other vulnerabilities in spree

- [CVE-2011-10019](https://insights.sbomify.com/CVE-2011-10019/): Spreecommerce < 0.60.2 Search Parameter RCE (critical 10.0)
- [CVE-2011-10026](https://insights.sbomify.com/CVE-2011-10026/): Spreecommerce < 0.50.x API RCE (critical 9.3)
- [CVE-2026-25757](https://insights.sbomify.com/CVE-2026-25757/): Unauthenticated Spree Commerce users can view completed guest orders by Order ID (high 7.7)
- [CVE-2026-25758](https://insights.sbomify.com/CVE-2026-25758/): Spree allows unauthenticated users can access all guest addresses (high 7.7)
- [CVE-2020-26223](https://insights.sbomify.com/CVE-2020-26223/): Authorization bypass in Spree (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22589 and fix it if it is affected.

What it is: CVE-2026-22589 is a high-severity missing authorization vulnerability in spree, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22589 exists.

Affected packages and fixed versions:
- spree_core (RubyGems): affected from 4.0.0; fixed in 4.10.2
- spree_core (RubyGems): affected from 4.0.0; fixed in 4.10.2
- spree_core (RubyGems): affected from 5.0.0; fixed in 5.0.7
- spree_core (RubyGems): affected from 5.0.0; fixed in 5.0.7
- spree_core (RubyGems): affected from 5.1.0; fixed in 5.1.9
- spree_core (RubyGems): affected from 5.1.0; fixed in 5.1.9
- spree_core (RubyGems): affected from 5.2.0; fixed in 5.2.5
- spree_core (RubyGems): affected from 5.2.0; fixed in 5.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22589/ (Markdown: https://insights.sbomify.com/CVE-2026-22589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22589
- OSV: https://osv.dev/vulnerability/CVE-2026-22589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22589/
Summaries are generated and may contain mistakes; the official description above is the record.
