CVE-2026-22592 Gogs is Vulnerable to Denial of Service
An authenticated user can crash the Gogs Git service by deleting a repository file before synchronization, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-22592?
CVE-2026-22592 is a medium-severity denial of service vulnerability in gogs, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, an authenticated user can cause a DOS attack. If one of the repo files is deleted before synchronization, it will cause the application to crash. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Weakness: CWE-862
Which versions are affected by CVE-2026-22592?
3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gogs.io/gogs Go | All versions | None |
gogs.io/gogs Go | All versions | 0.13.4 |
gogs.io/gogs Go | All versions | 0.13.4 |
Products include Gogs Gogs.
How do I fix CVE-2026-22592?
Upgrade gogs.io/gogs to 0.13.4 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-22592 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22592 exists.
Other vulnerabilities in gogs
Sources
Also known as GHSA-cr88-6mqm-4g57, GO-2026-4451.