CVE-2026-22599 Strapi Vulnerable to SQL Injection in Content Type Builder

Critical 9.3 Published Updated

Authenticated administrators can execute arbitrary SQL commands via the Content-Type Builder API, potentially leading to remote code execution or data theft.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-22599?

CVE-2026-22599 is a critical SQL injection vulnerability in @strapi/content-type-builder, published on 14 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Strapi is an open source headless content management system. In versions on the 4.x branch prior to 4.26.1 and on the 5.x branch prior to 5.33.2, a database-query injection vulnerability existed in the Strapi Content-Type Builder write API. An authenticated administrator could inject arbitrary database statements through the `column.defaultTo` attribute when creating or modifying a content type. Setting `defaultTo` as a tuple `[value, { isRaw: true }]` caused the value to be passed directly into Knex's `db.connection.raw()` during schema migration without sanitization, allowing arbitrary statement execution at the database layer. Depending on the database engine, this enabled arbitrary file read via database utility functions, denial of service via forced server crash on schema-migration error, and on engines that permit external program execution, remote code execution against the database server. The patch in versions 4.26.1 and 5.33.2 addresses this by restricting all Content-Type Builder write APIs to development mode only. Production deployments running v5.33.2 or later return 404 for requests against `/content-type-builder/content-types` and related endpoints, removing the network-reachable attack surface entirely.

Weakness: CWE-89

Which versions are affected by CVE-2026-22599?

4 open source packages ship an affected version, including @strapi/content-type-builder and @strapi/plugin-content-type-builder. It affects 1 product.

PackageAffectedFixed in
@strapi/content-type-builder npmFrom 5.0.05.33.2
@strapi/content-type-builder npmFrom 5.0.05.33.2
@strapi/plugin-content-type-builder npmFrom 4.0.04.26.1
@strapi/plugin-content-type-builder npmFrom 4.0.04.26.1

Products include Strapi Strapi.

How do I fix CVE-2026-22599?

Upgrade @strapi/content-type-builder to 5.33.2 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-22599 being exploited?

There is no known exploitation of CVE-2026-22599 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-3xcq-8mjw-h6mx.

Is CVE-2026-22599 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free