# CVE-2026-22607: Fickling Blocklist Bypass: cProfile.run()

> Fickling misclassifies malicious pickles using cProfile.run(), allowing attackers to execute code if users rely on it for safety checks.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-p523-jq9w-64x9, PYSEC-2026-1371

## What is CVE-2026-22607?

CVE-2026-22607 is a high-severity unsafe deserialization vulnerability in trailofbits fickling, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fickling is a Python pickling decompiler and static analyzer. Fickling versions up to and including 0.1.6 do not treat Python's cProfile module as unsafe. Because of this, a malicious pickle that uses cProfile.run() is classified as SUSPICIOUS instead of OVERTLY_MALICIOUS. If a user relies on Fickling's output to decide whether a pickle is safe to deserialize, this misclassification can lead them to execute attacker-controlled code on their system. This affects any workflow or product that uses Fickling as a security gate for pickle deserialization. This issue has been patched in version 0.1.7.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-22607?

3 open source packages ship an affected version, including fickling. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fickling` | PyPI | All versions | 0.1.7 |
| `fickling` | PyPI | All versions | 0.1.7 |
| `fickling` | PyPI | All versions | 0.1.7 |

Products: Trailofbits Fickling.

## How do I fix CVE-2026-22607?

Upgrade fickling to 0.1.7 or later.

## Is CVE-2026-22607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22607 exists.

## Other vulnerabilities in trailofbits fickling

- [CVE-2026-22606](https://insights.sbomify.com/CVE-2026-22606/): Fickling has a bypass via runpy.run_path() and runpy.run_module() (high 8.9)
- [CVE-2026-22608](https://insights.sbomify.com/CVE-2026-22608/): Fickling vulnerable to use of ctypes and pydoc gadget chain to bypass detection (high 8.9)
- [CVE-2026-22609](https://insights.sbomify.com/CVE-2026-22609/): Fickling has Static Analysis Bypass via Incomplete Dangerous Module Blocklist (high 8.9)
- [CVE-2026-22612](https://insights.sbomify.com/CVE-2026-22612/): Fickling vulnerable to detection bypass due to "builtins" blindness (high 8.9)
- [CVE-2026-14534](https://insights.sbomify.com/CVE-2026-14534/): Fickling check_safety() bypass via unlisted standard library modules (_posixsubprocess, site, atexit) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22607 and fix it if it is affected.

What it is: CVE-2026-22607 is a high-severity unsafe deserialization vulnerability in trailofbits fickling, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22607 exists.

Affected packages and fixed versions:
- fickling (PyPI): affected all versions; fixed in 0.1.7
- fickling (PyPI): affected all versions; fixed in 0.1.7
- fickling (PyPI): affected all versions; fixed in 0.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22607/ (Markdown: https://insights.sbomify.com/CVE-2026-22607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22607
- OSV: https://osv.dev/vulnerability/CVE-2026-22607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22607/
Summaries are generated and may contain mistakes; the official description above is the record.
