CVE-2026-22610 Angular has XSS Vulnerability via Unsanitized SVG Script Attributes
Attackers can execute arbitrary scripts via unsanitized SVG script attributes in Angular applications, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-22610?
CVE-2026-22610 is a high-severity cross-site scripting vulnerability in angular, published on 10 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-22610?
20 open source packages ship an affected version, including @angular/compiler and @angular/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@angular/compiler npm | All versions to 18.2.14 | None |
@angular/compiler npm | All versions to 18.2.14 | None |
@angular/compiler npm | From 19.0.0-next.0 | 19.2.18 |
@angular/compiler npm | From 19.0.0-next.0 | 19.2.18 |
@angular/compiler npm | From 20.0.0-next.0 | 20.3.16 |
@angular/compiler npm | From 20.0.0-next.0 | 20.3.16 |
14 more packages
@angular/compiler npm | From 21.0.0-next.0 | 21.0.7 |
@angular/compiler npm | From 21.0.0-next.0 | 21.0.7 |
@angular/compiler npm | From 21.1.0-next.0 | 21.1.0-rc.0 |
@angular/compiler npm | From 21.1.0-next.0 | 21.1.0-rc.0 |
@angular/core npm | All versions to 18.2.14 | None |
@angular/core npm | All versions to 18.2.14 | None |
@angular/core npm | From 19.0.0-next.0 | 19.2.18 |
@angular/core npm | From 19.0.0-next.0 | 19.2.18 |
@angular/core npm | From 20.0.0-next.0 | 20.3.16 |
@angular/core npm | From 20.0.0-next.0 | 20.3.16 |
@angular/core npm | From 21.0.0-next.0 | 21.0.7 |
@angular/core npm | From 21.0.0-next.0 | 21.0.7 |
@angular/core npm | From 21.1.0-next.0 | 21.1.0-rc.0 |
@angular/core npm | From 21.1.0-next.0 | 21.1.0-rc.0 |
Products include Angular Angular.
How do I fix CVE-2026-22610?
Upgrade @angular/compiler to a fixed version for your release line: 19.2.18, 20.3.16, 21.0.7 or 21.1.0-rc.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-22610 being exploited?
There is no known exploitation of CVE-2026-22610 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in angular
- CVE-2026-68945 Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning
- CVE-2026-46417 Angular: SSRF via Hostname Hijacking in @angular/platform-server
- CVE-2026-50168 Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass
- CVE-2026-54266 Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning
- CVE-2026-41423 Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server
Sources
Also known as CLSA-2026-1774657389, CLSA-2026-1775176141, CLSA-2026-1775176145, CLSA-2026-1775176149, CLSA-2026-1775176156, CLSA-2026-1775176158 and 186 more.