{"answers":{"affected":"2 open source packages ship an affected version, including AWSSDK.Core.","exploited":"There is no known exploitation of CVE-2026-22611 in the wild and no public exploit code.","fix":"Upgrade AWSSDK.Core to 4.0.3.3 or later.","what":"CVE-2026-22611 is a low-severity server-side request forgery vulnerability in aws-sdk-net, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22611 and fix it if it is affected.\n\nWhat it is: CVE-2026-22611 is a low-severity server-side request forgery vulnerability in aws-sdk-net, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-22611 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- AWSSDK.Core (NuGet): affected from 4.0.0; fixed in 4.0.3.3\n- AWSSDK.Core (NuGet): affected from 4.0.0; fixed in 4.0.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22611/ (Markdown: https://insights.sbomify.com/CVE-2026-22611/index.md)","id":"CVE-2026-22611","markdown":"https://insights.sbomify.com/CVE-2026-22611/index.md","name":"CVE-2026-22611","record":{"aliases":["GHSA-9cvc-h2w8-phrp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"AWS SDK for .NET","requires_auth":"none","summary":"An attacker with environment access can manipulate region parameters to route AWS API calls to non-AWS hosts, bypassing intended security controls.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"AWS SDK for .NET works with Amazon Web Services to help build scalable solutions with Amazon S3, Amazon DynamoDB, Amazon Glacier, and more. From versions 4.0.0 to before 4.0.3.3, Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value. This issue has been patched in version 4.0.3.3.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AWS SDK for .NET V4 adopted defense in depth enhancement for region parameter value","id":"CVE-2026-22611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Fickling vulnerable to detection bypass due to \"builtins\" blindness","id":"CVE-2026-22612"},"packages":[{"ecosystem":"NuGet","fixed":["4.0.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"AWSSDK.Core","purl":null,"source":"GHSA-9cvc-h2w8-phrp"},{"ecosystem":"NuGet","fixed":["4.0.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"AWSSDK.Core","purl":"pkg:nuget/AWSSDK.Core","source":"GHSA-9cvc-h2w8-phrp"}],"prev":{"headline":"Angular has XSS Vulnerability via Unsanitized SVG Script Attributes","id":"CVE-2026-22610"},"products":["aws-sdk-net"],"published":"2026-01-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-12","vendors":["aws"]},"summary":"An attacker with environment access can manipulate region parameters to route AWS API calls to non-AWS hosts, bypassing intended security controls.","url":"https://insights.sbomify.com/CVE-2026-22611/"}