# CVE-2026-22611: AWS SDK for .NET V4 adopted defense in depth enhancement for region parameter value

> An attacker with environment access can manipulate region parameters to route AWS API calls to non-AWS hosts, bypassing intended security controls.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-9cvc-h2w8-phrp

## What is CVE-2026-22611?

CVE-2026-22611 is a low-severity server-side request forgery vulnerability in aws-sdk-net, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AWS SDK for .NET works with Amazon Web Services to help build scalable solutions with Amazon S3, Amazon DynamoDB, Amazon Glacier, and more. From versions 4.0.0 to before 4.0.3.3, Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value. This issue has been patched in version 4.0.3.3.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-22611?

2 open source packages ship an affected version, including AWSSDK.Core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `AWSSDK.Core` | NuGet | From 4.0.0 | 4.0.3.3 |
| `AWSSDK.Core` | NuGet | From 4.0.0 | 4.0.3.3 |

## How do I fix CVE-2026-22611?

Upgrade AWSSDK.Core to 4.0.3.3 or later.

## Is CVE-2026-22611 being exploited?

There is no known exploitation of CVE-2026-22611 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22611 and fix it if it is affected.

What it is: CVE-2026-22611 is a low-severity server-side request forgery vulnerability in aws-sdk-net, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22611 in the wild and no public exploit code.

Affected packages and fixed versions:
- AWSSDK.Core (NuGet): affected from 4.0.0; fixed in 4.0.3.3
- AWSSDK.Core (NuGet): affected from 4.0.0; fixed in 4.0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22611/ (Markdown: https://insights.sbomify.com/CVE-2026-22611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22611
- OSV: https://osv.dev/vulnerability/CVE-2026-22611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22611/
Summaries are generated and may contain mistakes; the official description above is the record.
