CVE-2026-22627 Memory corruption in FortiSwitchAXFixed

High 7.7 Published Updated

An unauthenticated attacker on the adjacent network can execute arbitrary code via a crafted LLDP packet due to a buffer overflow in FortiSwitchAXFixed.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-22627?

CVE-2026-22627 is a high-severity memory corruption vulnerability in Fortinet FortiSwitchAXFixed, published on 10 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A buffer copy without checking size of input ('classic buffer overflow') vulnerability in Fortinet FortiSwitchAXFixed 1.0.0 through 1.0.1 may allow an unauthenticated attacker within the same adjacent network to execute unauthorized code or commands on the device via sending a crafted LLDP packet.

Weakness: CWE-120

Which versions are affected by CVE-2026-22627?

It affects 1 product.

Products include Fortinet Fortiswitchaxfixed.

How do I fix CVE-2026-22627?

No fix has been published for CVE-2026-22627 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-22627 being exploited?

There is no known exploitation of CVE-2026-22627 in the wild and no public exploit code.

Sources

Also known as GHSA-cj8g-r35p-7p2v.

Is CVE-2026-22627 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free