# CVE-2026-22686: Sandbox Escape via Host Error Prototype Chain in enclave-vm

> Attackers can escape the JavaScript sandbox to execute arbitrary code on the host Node.js runtime by exploiting the host Error prototype chain.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2026
- **Updated:** 14 Jan 2026
- **Also known as:** GHSA-7qm7-455j-5p63

## What is CVE-2026-22686?

CVE-2026-22686 is a critical code injection vulnerability in agentfront enclave, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Enclave is a secure JavaScript sandbox designed for safe AI agent code execution. Prior to 2.7.0, there is a critical sandbox escape vulnerability in enclave-vm that allows untrusted, sandboxed JavaScript code to execute arbitrary code in the host Node.js runtime. When a tool invocation fails, enclave-vm exposes a host-side Error object to sandboxed code. This Error object retains its host realm prototype chain, which can be traversed to reach the host Function constructor. An attacker can intentionally trigger a host error, then climb the prototype chain. Using the host Function constructor, arbitrary JavaScript can be compiled and executed in the host context, fully bypassing the sandbox and granting access to sensitive resources such as process.env, filesystem, and network. This breaks enclave-vm’s core security guarantee of isolating untrusted code. This vulnerability is fixed in 2.7.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-22686?

2 open source packages ship an affected version, including enclave-vm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `enclave-vm` | npm | All versions | 2.7.0 |
| `enclave-vm` | npm | All versions | 2.7.0 |

Products: Agentfront Enclave.

## How do I fix CVE-2026-22686?

Upgrade enclave-vm to 2.7.0 or later.

## Is CVE-2026-22686 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22686 exists.

Public exploit code:

- https://github.com/moltengama/CVE-2026-22686-RemoteCodeExecution-RCE-PoC (github_poc): https://github.com/moltengama/CVE-2026-22686-RemoteCodeExecution-RCE-PoC
- https://github.com/amusedx/CVE-2026-22686 (github_poc): https://github.com/amusedx/CVE-2026-22686
- CVE-2026-22686-RemoteCodeExecution-RCE-PoC (github_poc): https://github.com/moi404/CVE-2026-22686-RemoteCodeExecution-RCE-PoC

## Other vulnerabilities in agentfront enclave

- [CVE-2026-27597](https://insights.sbomify.com/CVE-2026-27597/): @enclave-vm/core is vulnerable to Sandbox Escape (critical 10.0)
- [CVE-2026-25533](https://insights.sbomify.com/CVE-2026-25533/): Enclave has a sandbox escape via infinite recursion and error objects (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22686 and fix it if it is affected.

What it is: CVE-2026-22686 is a critical code injection vulnerability in agentfront enclave, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22686 exists.

Affected packages and fixed versions:
- enclave-vm (npm): affected all versions; fixed in 2.7.0
- enclave-vm (npm): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22686/ (Markdown: https://insights.sbomify.com/CVE-2026-22686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22686
- OSV: https://osv.dev/vulnerability/CVE-2026-22686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22686/
Summaries are generated and may contain mistakes; the official description above is the record.
