# CVE-2026-22689: Mailpit is vulnerable to Cross-Site WebSocket Hijacking (CSWSH) allowing unauthenticated access to emails

> An attacker can hijack WebSocket connections to read sensitive email data from a local Mailpit instance via a malicious website.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-524m-q5m7-79mm, GO-2026-4310

## What is CVE-2026-22689?

CVE-2026-22689 is a medium-severity vulnerability in axllent mailpit, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mailpit is an email testing tool and API for developers. Prior to version 1.28.2, the Mailpit WebSocket server is configured to accept connections from any origin. This lack of Origin header validation introduces a Cross-Site WebSocket Hijacking (CSWSH) vulnerability. An attacker can host a malicious website that, when visited by a developer running Mailpit locally, establishes a WebSocket connection to the victim's Mailpit instance (default ws://localhost:8025). This allows the attacker to intercept sensitive data such as email contents, headers, and server statistics in real-time. This issue has been patched in version 1.28.2.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2026-22689?

5 open source packages ship an affected version, including github.com/axllent/mailpit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/axllent/mailpit` | Go | All versions | 0.0.0-20260110031614 |
| `github.com/axllent/mailpit` | Go | All versions | 0.0.0-20260110031614 |
| `github.com/axllent/mailpit` | Go | From 1.2.6 | 1.28.2 |
| `github.com/axllent/mailpit` | Go | From 1.2.6 | 1.28.2 |
| `github.com/axllent/mailpit` | Go | From 1.2.6 | 1.28.2 |

Products: Axllent Mailpit.

## How do I fix CVE-2026-22689?

Upgrade github.com/axllent/mailpit to a fixed version for your release line: 0.0.0-20260110031614 or 1.28.2.

## Is CVE-2026-22689 being exploited?

There is no known exploitation of CVE-2026-22689 in the wild and no public exploit code.

## Other vulnerabilities in axllent mailpit

- [CVE-2026-45713](https://insights.sbomify.com/CVE-2026-45713/): Mailpit: Unauthenticated remote memory-exhaustion DoS via unlimited SMTP DATA and /api/v1/send body sizes (high 7.5)
- [CVE-2026-45711](https://insights.sbomify.com/CVE-2026-45711/): Mailpit: Path traversal & arbitrary file write in mailpit dump --http via attacker-controlled message IDs (medium 5.9)
- [CVE-2026-45712](https://insights.sbomify.com/CVE-2026-45712/): Mailpit: Concurrent map read & write in proxy CSS rewriter - remote unauth crash (fatal error: concurrent map read and map write) (medium 5.9)
- [CVE-2026-45709](https://insights.sbomify.com/CVE-2026-45709/): Mailpit has an incomplete fix for GHSA-6jxm: HTML check still permits SSRF to private/loopback/IMDS via missing IP-filter dialer (medium 5.8)
- [CVE-2026-27808](https://insights.sbomify.com/CVE-2026-27808/): Mailpit is Vulnerable to Server-Side Request Forgery (SSRF) via Link Check API (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22689 and fix it if it is affected.

What it is: CVE-2026-22689 is a medium-severity vulnerability in axllent mailpit, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-22689 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/axllent/mailpit (Go): affected all versions; fixed in 0.0.0-20260110031614
- github.com/axllent/mailpit (Go): affected all versions; fixed in 0.0.0-20260110031614
- github.com/axllent/mailpit (Go): affected from 1.2.6; fixed in 1.28.2
- github.com/axllent/mailpit (Go): affected from 1.2.6; fixed in 1.28.2
- github.com/axllent/mailpit (Go): affected from 1.2.6; fixed in 1.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22689/ (Markdown: https://insights.sbomify.com/CVE-2026-22689/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22689
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22689
- OSV: https://osv.dev/vulnerability/CVE-2026-22689

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22689/
Summaries are generated and may contain mistakes; the official description above is the record.
