# CVE-2026-22692: October CMS: Twig Sandbox Bypass via Collection Methods

> Authenticated users with template editing permissions can bypass Twig sandbox protections in October CMS when safe mode is enabled, potentially executing arbitrary code.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-m5qg-jc75-4jp6

## What is CVE-2026-22692?

CVE-2026-22692 is a medium-severity vulnerability in Octobercms October, published on 14 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

October is a Content Management System (CMS) and web platform. Versions prior to 3.7.13 and versions 4.0.0 through 4.1.4 contain a sandbox bypass vulnerability in the optional Twig safe mode feature (CMS_SAFE_MODE). Certain methods on the collect() helper were not properly restricted, allowing authenticated users with template editing permissions to bypass sandbox protections. Exploitation requires authenticated backend access with CMS template editing permissions and only affects installations with CMS_SAFE_MODE enabled (disabled by default). This issue has been fixed in versions 3.7.13 and 4.1.5. To workaround this issue, users can disable CMS_SAFE_MODE if untrusted template editing is not required, and restrict CMS template editing permissions to fully trusted administrators only.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-22692?

4 open source packages ship an affected version, including october/rain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/rain` | Packagist | All versions | 3.7.13 |
| `october/rain` | Packagist | All versions | 3.7.13 |
| `october/rain` | Packagist | From 4.0.0 | 4.1.5 |
| `october/rain` | Packagist | From 4.0.0 | 4.1.5 |

Products: Octobercms October.

## How do I fix CVE-2026-22692?

Upgrade october/rain to a fixed version for your release line: 3.7.13 or 4.1.5.

## Is CVE-2026-22692 being exploited?

There is no known exploitation of CVE-2026-22692 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-22692 - Critical Twig Sandbox Bypass via collect()->mapInto() allowing RCE/LFI/XXE in October CMS (github_poc): https://github.com/lukasz-rybak/CVE-2026-22692

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22692 and fix it if it is affected.

What it is: CVE-2026-22692 is a medium-severity vulnerability in Octobercms October, published on 14 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22692 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/rain (Packagist): affected all versions; fixed in 3.7.13
- october/rain (Packagist): affected all versions; fixed in 3.7.13
- october/rain (Packagist): affected from 4.0.0; fixed in 4.1.5
- october/rain (Packagist): affected from 4.0.0; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22692/ (Markdown: https://insights.sbomify.com/CVE-2026-22692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22692
- OSV: https://osv.dev/vulnerability/CVE-2026-22692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22692/
Summaries are generated and may contain mistakes; the official description above is the record.
