CVE-2026-22696 dcap-qvl has Missing Verification for QE Identity

Critical 9.3 Published Updated

Attackers can forge QE Identity data to bypass remote attestation verification, allowing acceptance of untrusted quotes in SGX or TDX environments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-22696?

CVE-2026-22696 is a critical vulnerability in Phala-Network dcap-qvl, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

dcap-qvl implements the quote verification logic for DCAP (Data Center Attestation Primitives). A vulnerability present in versions prior to 0.3.9 involves a critical gap in the cryptographic verification process within the dcap-qvl. The library fetches QE Identity collateral (including qe_identity, qe_identity_signature, and qe_identity_issuer_chain) from the PCCS. However, it skips to verify the QE Identity signature against its certificate chain and does not enforce policy constraints on the QE Report. An attacker can forge the QE Identity data to whitelist a malicious or non-Intel Quoting Enclave. This allows the attacker to forge the QE and sign untrusted quotes that the verifier will accept as valid. Effectively, this bypasses the entire remote attestation security model, as the verifier can no longer trust the entity responsible for signing the quotes. All deployments utilizing the dcap-qvl library for SGX or TDX quote verification are affected. The vulnerability has been patched in dcap-qvl version 0.3.9. The fix implements the missing cryptographic verification for the QE Identity signature and enforces the required checks for MRSIGNER, ISVPRODID, and ISVSVN against the QE Report. Users of the `@phala/dcap-qvl-node` and `@phala/dcap-qvl-web` packages should switch to the pure JavaScript implementation, `@phala/dcap-qvl`. There are no known workarounds for this vulnerability. Users must upgrade to the patched version to ensure that QE Identity collateral is properly verified.

Weakness: CWE-347, CWE-295

Which versions are affected by CVE-2026-22696?

11 open source packages ship an affected version, including dcap-qvl, @phala/dcap-qvl and @phala/dcap-qvl-node.

PackageAffectedFixed in
dcap-qvl PyPIAll versions0.3.9
dcap-qvl PyPIAll versions0.3.9
dcap-qvl PyPIAll versions0.3.9
dcap-qvl crates.ioAll versions0.3.9
dcap-qvl crates.ioAll versions0.3.9
@phala/dcap-qvl npmAll versions0.3.9
5 more packages
@phala/dcap-qvl npmAll versions0.3.9
@phala/dcap-qvl-node npmAll versions to 0.3.3None
@phala/dcap-qvl-node npmAll versions to 0.3.3None
@phala/dcap-qvl-web npmAll versions to 0.3.3None
@phala/dcap-qvl-web npmAll versions to 0.3.3None

How do I fix CVE-2026-22696?

Upgrade dcap-qvl to 0.3.9 or later.

Is CVE-2026-22696 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22696 exists.

Sources

Also known as GHSA-796p-j2gh-9m2q, PYSEC-2026-326.

Is CVE-2026-22696 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free