# CVE-2026-22696: dcap-qvl has Missing Verification for QE Identity

> Attackers can forge QE Identity data to bypass remote attestation verification, allowing acceptance of untrusted quotes in SGX or TDX environments.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-796p-j2gh-9m2q, PYSEC-2026-326

## What is CVE-2026-22696?

CVE-2026-22696 is a critical vulnerability in Phala-Network dcap-qvl, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dcap-qvl implements the quote verification logic for DCAP (Data Center Attestation Primitives). A vulnerability present in versions prior to 0.3.9 involves a critical gap in the cryptographic verification process within the dcap-qvl. The library fetches QE Identity collateral (including qe_identity, qe_identity_signature, and qe_identity_issuer_chain) from the PCCS. However, it skips to verify the QE Identity signature against its certificate chain and does not enforce policy constraints on the QE Report. An attacker can forge the QE Identity data to whitelist a malicious or non-Intel Quoting Enclave. This allows the attacker to forge the QE and sign untrusted quotes that the verifier will accept as valid. Effectively, this bypasses the entire remote attestation security model, as the verifier can no longer trust the entity responsible for signing the quotes. All deployments utilizing the dcap-qvl library for SGX or TDX quote verification are affected. The vulnerability has been patched in dcap-qvl version 0.3.9. The fix implements the missing cryptographic verification for the QE Identity signature and enforces the required checks for MRSIGNER, ISVPRODID, and ISVSVN against the QE Report. Users of the `@phala/dcap-qvl-node` and `@phala/dcap-qvl-web` packages should switch to the pure JavaScript implementation, `@phala/dcap-qvl`. There are no known workarounds for this vulnerability. Users must upgrade to the patched version to ensure that QE Identity collateral is properly verified.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-22696?

11 open source packages ship an affected version, including dcap-qvl, @phala/dcap-qvl and @phala/dcap-qvl-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dcap-qvl` | PyPI | All versions | 0.3.9 |
| `dcap-qvl` | PyPI | All versions | 0.3.9 |
| `dcap-qvl` | PyPI | All versions | 0.3.9 |
| `dcap-qvl` | crates.io | All versions | 0.3.9 |
| `dcap-qvl` | crates.io | All versions | 0.3.9 |
| `@phala/dcap-qvl` | npm | All versions | 0.3.9 |
| `@phala/dcap-qvl` | npm | All versions | 0.3.9 |
| `@phala/dcap-qvl-node` | npm | All versions to 0.3.3 | None |
| `@phala/dcap-qvl-node` | npm | All versions to 0.3.3 | None |
| `@phala/dcap-qvl-web` | npm | All versions to 0.3.3 | None |
| `@phala/dcap-qvl-web` | npm | All versions to 0.3.3 | None |

## How do I fix CVE-2026-22696?

Upgrade dcap-qvl to 0.3.9 or later.

## Is CVE-2026-22696 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22696 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22696 and fix it if it is affected.

What it is: CVE-2026-22696 is a critical vulnerability in Phala-Network dcap-qvl, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22696 exists.

Affected packages and fixed versions:
- dcap-qvl (PyPI): affected all versions; fixed in 0.3.9
- dcap-qvl (PyPI): affected all versions; fixed in 0.3.9
- dcap-qvl (PyPI): affected all versions; fixed in 0.3.9
- dcap-qvl (crates.io): affected all versions; fixed in 0.3.9
- dcap-qvl (crates.io): affected all versions; fixed in 0.3.9
- @phala/dcap-qvl (npm): affected all versions; fixed in 0.3.9
- @phala/dcap-qvl (npm): affected all versions; fixed in 0.3.9
- @phala/dcap-qvl-node (npm): affected all versions up to 0.3.3; no fix listed
- @phala/dcap-qvl-node (npm): affected all versions up to 0.3.3; no fix listed
- @phala/dcap-qvl-web (npm): affected all versions up to 0.3.3; no fix listed
- @phala/dcap-qvl-web (npm): affected all versions up to 0.3.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22696/ (Markdown: https://insights.sbomify.com/CVE-2026-22696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22696
- OSV: https://osv.dev/vulnerability/CVE-2026-22696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22696/
Summaries are generated and may contain mistakes; the official description above is the record.
