CVE-2026-22704 HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover

High 8.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-22704?

CVE-2026-22704 is a high-severity vulnerability in haxtheweb issues, published on 10 Jan 2026.

Official description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-22704?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.

PackageAffectedFixed in
@haxtheweb/haxcms-nodejs npmFrom 11.0.625.0.0
@haxtheweb/haxcms-nodejs npmFrom 11.0.625.0.0

Products include Psu Haxcms-Nodejs.

How do I fix CVE-2026-22704?

Upgrade @haxtheweb/haxcms-nodejs to 25.0.0 or later.

Is CVE-2026-22704 being exploited?

There is no known exploitation of CVE-2026-22704 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as GHSA-3fm2-xfq7-7778.

Is CVE-2026-22704 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free