# CVE-2026-22704: HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-3fm2-xfq7-7778

## What is CVE-2026-22704?

CVE-2026-22704 is a high-severity vulnerability in haxtheweb issues, published on 10 Jan 2026. 

### Official description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-22704?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | From 11.0.6 | 25.0.0 |
| `@haxtheweb/haxcms-nodejs` | npm | From 11.0.6 | 25.0.0 |

Products: Psu Haxcms-Nodejs.

## How do I fix CVE-2026-22704?

Upgrade @haxtheweb/haxcms-nodejs to 25.0.0 or later.

## Is CVE-2026-22704 being exploited?

There is no known exploitation of CVE-2026-22704 in the wild and no public exploit code.

Public exploit code:

- HAX CMS 24.x - Stored Cross-Site Scripting (XSS) (exploitdb)

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-54127](https://insights.sbomify.com/CVE-2025-54127/): HAXcms's Insecure Default Configuration Leads to Unauthenticated Access (critical 9.3)
- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-49137](https://insights.sbomify.com/CVE-2025-49137/): Hax CMS Stored Cross-Site Scripting vulnerability (high 8.5)
- [CVE-2025-54378](https://insights.sbomify.com/CVE-2025-54378/): HAX CMS Backend Lacks Comprehensive Authorization Checks (high 8.3)
- [CVE-2025-54137](https://insights.sbomify.com/CVE-2025-54137/): NodeJS version of the HAX CMS application is distributed with Default Secrets (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22704 and fix it if it is affected.

What it is: CVE-2026-22704 is a high-severity vulnerability in haxtheweb issues, published on 10 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2026-22704 in the wild and no public exploit code.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected from 11.0.6; fixed in 25.0.0
- @haxtheweb/haxcms-nodejs (npm): affected from 11.0.6; fixed in 25.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22704/ (Markdown: https://insights.sbomify.com/CVE-2026-22704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22704
- OSV: https://osv.dev/vulnerability/CVE-2026-22704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22704/
Summaries are generated and may contain mistakes; the official description above is the record.
