CVE-2026-22732 Under Some Conditions Spring Security HTTP Headers Are not Written
Attackers may bypass security controls because Spring Security fails to write HTTP response headers in certain servlet application conditions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-22732?
CVE-2026-22732 is a critical vulnerability in VMware Spring Security, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When applications specify HTTP response headers for servlet applications using Spring Security, there is the possibility that the HTTP Headers will not be written. This issue affects Spring Security Servlet applications using lazy (default) writing of HTTP Headers:
: from 5.7.0 through 5.7.21, from 5.8.0 through 5.8.23, from 6.3.0 through 6.3.14, from 6.4.0 through 6.4.14, from 6.5.0 through 6.5.8, from 7.0.0 through 7.0.3.
Weakness: CWE-425
Which versions are affected by CVE-2026-22732?
12 open source packages ship an affected version, including org.springframework.security:spring-security-web. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-web Maven | All versions to 5.7.14 | None |
org.springframework.security:spring-security-web Maven | All versions to 5.7.14 | None |
org.springframework.security:spring-security-web Maven | From 5.8.0 to 5.8.16 | None |
org.springframework.security:spring-security-web Maven | From 5.8.0 to 5.8.16 | None |
org.springframework.security:spring-security-web Maven | From 6.0.0 to 6.3.10 | None |
org.springframework.security:spring-security-web Maven | From 6.0.0 to 6.3.10 | None |
6 more packages
org.springframework.security:spring-security-web Maven | From 6.4.0 to 6.4.13 | None |
org.springframework.security:spring-security-web Maven | From 6.4.0 to 6.4.13 | None |
org.springframework.security:spring-security-web Maven | From 6.5.0 | 6.5.9 |
org.springframework.security:spring-security-web Maven | From 6.5.0 | 6.5.9 |
org.springframework.security:spring-security-web Maven | From 7.0.0 | 7.0.4 |
org.springframework.security:spring-security-web Maven | From 7.0.0 | 7.0.4 |
Products include Vmware Spring Security.
How do I fix CVE-2026-22732?
Upgrade org.springframework.security:spring-security-web to a fixed version for your release line: 6.5.9 or 7.0.4.
Is CVE-2026-22732 being exploited?
There is no known exploitation of CVE-2026-22732 in the wild and no public exploit code.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in VMware Spring Security
- CVE-2014-3527 Authorization Bypass in Spring Security
- CVE-2026-59354 Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata
- CVE-2026-59270 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces
- CVE-2023-34034 Access Control Bypass in Spring Security
- CVE-2026-47877 Spring Security Authorization Server Default Consent Page is vulnerable to Cross-Site Scripting (XSS)
Sources
Also known as CLEANSTART-2026-AQ60759, CLEANSTART-2026-DZ61403, CLEANSTART-2026-RV47518, CLEANSTART-2026-WO59717, CLSA-2026-1774225197, CLSA-2026-1774398071 and 16 more.