# CVE-2026-22738: SpEL Injection via Unescaped Filter Key in SimpleVectorStore Leads to Remote Code Execution

> Attackers can execute arbitrary code via SpEL injection in SimpleVectorStore if user input is used as a filter key.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 10 May 2026
- **Also known as:** GHSA-fvh3-672c-7p6c

## What is CVE-2026-22738?

CVE-2026-22738 is a critical code injection vulnerability in Spring AI, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Spring AI, a SpEL injection vulnerability exists in SimpleVectorStore when a user-supplied value is used as a filter expression key. A malicious actor could exploit this to execute arbitrary code. Only applications that use SimpleVectorStore and pass user-supplied input as a filter expression key are affected.
This issue affects Spring AI: from 1.0.0 before 1.0.5, from 1.1.0 before 1.1.4.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement), CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-22738?

4 open source packages ship an affected version, including org.springframework.ai:spring-ai-vector-store. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.ai:spring-ai-vector-store` | Maven | From 1.0.0 | 1.0.5 |
| `org.springframework.ai:spring-ai-vector-store` | Maven | From 1.0.0 | 1.0.5 |
| `org.springframework.ai:spring-ai-vector-store` | Maven | From 1.1.0-M1 | 1.1.4 |
| `org.springframework.ai:spring-ai-vector-store` | Maven | From 1.1.0-M1 | 1.1.4 |

Products: Vmware Spring Ai.

## How do I fix CVE-2026-22738?

Upgrade org.springframework.ai:spring-ai-vector-store to a fixed version for your release line: 1.0.5 or 1.1.4.

## Is CVE-2026-22738 being exploited?

There is no known exploitation of CVE-2026-22738 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2026-22738 (github_poc): https://github.com/n0n4m3x41/CVE-2026-22738-POC
- SpEL Injection via Unescaped Filter Key in SimpleVectorStore Leads to Remote Code Execution (github_poc): https://github.com/rockmelodies/CVE-2026-22738

## Other vulnerabilities in Spring AI

- [CVE-2026-40978](https://insights.sbomify.com/CVE-2026-40978/): Spring AI has SQL Injection in CosmosDBVectorStore.doDelete() (high 8.8)
- [CVE-2026-22730](https://insights.sbomify.com/CVE-2026-22730/): CVE-2026-22730: SQL Injection in Spring AI MariaDBFilterExpressionConverter (high 8.8)
- [CVE-2026-47835](https://insights.sbomify.com/CVE-2026-47835/): Spring AI vector store metadata filtering to handle special characters in Elasticsearch, OpenSearch, and GemFire Vector Stores (high 8.6)
- [CVE-2026-41705](https://insights.sbomify.com/CVE-2026-41705/): Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs (high 8.6)
- [CVE-2026-40967](https://insights.sbomify.com/CVE-2026-40967/): Spring AI has a VectorStore FilterExpression Converter injection (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22738 and fix it if it is affected.

What it is: CVE-2026-22738 is a critical code injection vulnerability in Spring AI, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22738 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.ai:spring-ai-vector-store (Maven): affected from 1.0.0; fixed in 1.0.5
- org.springframework.ai:spring-ai-vector-store (Maven): affected from 1.0.0; fixed in 1.0.5
- org.springframework.ai:spring-ai-vector-store (Maven): affected from 1.1.0-M1; fixed in 1.1.4
- org.springframework.ai:spring-ai-vector-store (Maven): affected from 1.1.0-M1; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22738/ (Markdown: https://insights.sbomify.com/CVE-2026-22738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22738
- OSV: https://osv.dev/vulnerability/CVE-2026-22738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22738/
Summaries are generated and may contain mistakes; the official description above is the record.
