# CVE-2026-22742: Server-Side Request Forgery in BedrockProxyChatModel via Unvalidated Media URL Fetching

> Attackers can exploit unvalidated media URLs in Spring AI to force server-side requests to internal or external destinations, potentially exposing sensitive data.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 10 May 2026
- **Also known as:** GHSA-mhrg-94vw-45c5, MINI-vc26-cjvr-rvmp, MINI-vx66-w43x-c84h

## What is CVE-2026-22742?

CVE-2026-22742 is a high-severity server-side request forgery vulnerability in Spring AI, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring AI's spring-ai-bedrock-converse contains a Server-Side Request Forgery (SSRF) vulnerability in BedrockProxyChatModel when processing multimodal messages that include user-supplied media URLs. Insufficient validation of those URLs allows an attacker to induce the server to issue HTTP requests to unintended internal or external destinations.
This issue affects Spring AI: from 1.0.0 before 1.0.5, from 1.1.0 before 1.1.4.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-22742?

4 open source packages ship an affected version, including org.springframework.ai:spring-ai-bedrock-converse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.ai:spring-ai-bedrock-converse` | Maven | From 1.0.0-M5 | 1.0.5 |
| `org.springframework.ai:spring-ai-bedrock-converse` | Maven | From 1.0.0-M5 | 1.0.5 |
| `org.springframework.ai:spring-ai-bedrock-converse` | Maven | From 1.1.0-M1 | 1.1.4 |
| `org.springframework.ai:spring-ai-bedrock-converse` | Maven | From 1.1.0-M1 | 1.1.4 |

Products: Vmware Spring Ai.

## How do I fix CVE-2026-22742?

Upgrade org.springframework.ai:spring-ai-bedrock-converse to a fixed version for your release line: 1.0.5 or 1.1.4.

## Is CVE-2026-22742 being exploited?

There is no known exploitation of CVE-2026-22742 in the wild and no public exploit code.

## Other vulnerabilities in Spring AI

- [CVE-2026-22738](https://insights.sbomify.com/CVE-2026-22738/): SpEL Injection via Unescaped Filter Key in SimpleVectorStore Leads to Remote Code Execution (critical 9.8)
- [CVE-2026-40978](https://insights.sbomify.com/CVE-2026-40978/): Spring AI has SQL Injection in CosmosDBVectorStore.doDelete() (high 8.8)
- [CVE-2026-22730](https://insights.sbomify.com/CVE-2026-22730/): CVE-2026-22730: SQL Injection in Spring AI MariaDBFilterExpressionConverter (high 8.8)
- [CVE-2026-47835](https://insights.sbomify.com/CVE-2026-47835/): Spring AI vector store metadata filtering to handle special characters in Elasticsearch, OpenSearch, and GemFire Vector Stores (high 8.6)
- [CVE-2026-41705](https://insights.sbomify.com/CVE-2026-41705/): Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22742 and fix it if it is affected.

What it is: CVE-2026-22742 is a high-severity server-side request forgery vulnerability in Spring AI, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22742 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.ai:spring-ai-bedrock-converse (Maven): affected from 1.0.0-M5; fixed in 1.0.5
- org.springframework.ai:spring-ai-bedrock-converse (Maven): affected from 1.0.0-M5; fixed in 1.0.5
- org.springframework.ai:spring-ai-bedrock-converse (Maven): affected from 1.1.0-M1; fixed in 1.1.4
- org.springframework.ai:spring-ai-bedrock-converse (Maven): affected from 1.1.0-M1; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22742/ (Markdown: https://insights.sbomify.com/CVE-2026-22742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22742
- OSV: https://osv.dev/vulnerability/CVE-2026-22742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22742/
Summaries are generated and may contain mistakes; the official description above is the record.
